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Preface
In this section:
Typographical Conventions ................................................................................. 5
Feedback............................................................................................................. 6

Typographical Conventions
Before you start using this guide, it is important to understand the documentation
conventions used in it.
The following kinds of formatting in the text identify special information.
Formatting convention

Type of Information

Example

Special Bold

Items you must select,
such as menu options,
command buttons, or
items in a list.

Go to the System tab.

Titles of chapters,
Read the Basic Administration
sections, and subsections. chapter.
Italics

Used to emphasize the
The system supports the so
importance of a point, to
called wildcard character search.
introduce a term or to
designate a command line
placeholder, which is to be
replaced with a real name
or value.

Monospace

The names of commands,
files, and directories.

The license file is located in the
http://docs/common/licen
ses directory.
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Formatting convention
Preformatted

Type of Information
On-screen computer
output in your commandline sessions; source code
in XML, C++, or other
programming languages.

Example
# ls –al /files
total 14470

Preformatted Bold

What you type, contrasted # cd /root/rpms/php
with on-screen computer
output.

CAPITALS

Names of keys on the
keyboard.

KEY+KEY

Key combinations for
CTRL+P, ALT+F4
which the user must press
and hold down one key
and then press another.

SHIFT, CTRL, ALT

Feedback
If you have found an error in this guide, or if you have suggestions or ideas on how to
improve this guide, please send your feedback using the online form at
http://www.parallels.com/en/support/usersdoc/. Please include in your report the guide's title,
chapter and section titles, and the fragment of text in which you have found an error.

CHAPTER 1

Overview of the Main Changes in the
Panel
This chapter is intended for hosting service customers who previously used Parallels
Plesk Panel version 9 and earlier. It describes the most important changes in the Panel
and addresses possible issues that the users might encounter after their accounts and
sites are moved to Parallels Plesk Panel 10 during the Panel upgrade.
Changes in user accounts
The new Control Panel introduces auxiliary users able to access Control Panel
together with the customer who created accounts for them. The auxiliary users replace
former Domain Administrators and mail users. The set of operations available to the
new Control Panel users is defined using a flexible system of user privileges based on
new user roles mechanism.
If you had domain administrator accounts in the previous version of Plesk, then it is
likely that after upgrade to Panel 10, they were converted to user accounts and
switched off. This is done for security reasons: a customer's user who is allowed to log
in to Control Panel for managing websites is able to view and manage all sites
belonging to the customer. For this reason, you should decide which of the users can
be allowed to log in to Control Panel again, and then switch the corresponding
accounts on.
Multi-domain hosting
The concept of a domain has been replaced with a concept of a subscription – a
hosting unit able to run multiple sites (domains and subdomains) over given resources
and services. Multi-domain hosting within one subscription is limited to one IP address.
Customers who need to host sites on different IP addresses are advised to obtain
additional subscriptions.
All sites in a subscription share the same SSL certificate. Customers who want to
protect all sites in a subscription should consider purchasing a multi-domain (a
wildcard) SSL certificate.
Customers no longer need to redistribute their resources across domains or
webspaces: Each webspace is allocated a fixed set of resources according to a hosting
plan.
Because subscriptions belong to customers, the domain administrator role is removed.
However, a customer is able to create user accounts that are eligible to manage all the
customer's sites.
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If you need to collaborate with other people on website content without allowing them
to log in to Control Panel, then you can create separate FTP accounts for them and
specify the directories to which they will have access.
New SiteBuilder 5.0
SiteBuilder 5.0 (former Parallels Plesk Sitebuilder) is the Panel component focused on
fast and efficient creation of websites.
When Plesk with SiteBuilder is upgraded to Parallels Plesk Panel 10, the SiteBuilder
component is not actually upgraded. Instead, the new SiteBuilder 5.0 is installed on the
server, and the SiteBuilder 4.5 remains operable, however, operations on websites
created in SiteBuilder 4.5 are limited to editing and publishing.
Transfer of websites from SiteBuilder 4.5 to SiteBuilder 5.0 is not supported.
We recommend that you create your new sites in SiteBuilder 5.0.
Single httpdocs directory to contain all web content
The option to use a separate directory for storing web content that should be accessed
over secure SSL connections is no longer available. All web content is now stored in a
single directory - httpdocs.
The httpsdocs directory may remain in the webspace after upgrading to Parallels
Plesk Panel 10, however, we recommend that you place all content in the httpdocs
directory when uploading files to the webspace over FTP.
If you used the option to keep SSL-protected and all other content in separate
directories, and had APS-packaged applications installed in the httpsdocs directory
of a website, then after upgrade, the Panel will switch on the compatibility mode for that
site. This will make the apps previously installed into httpsdocs directory accessible
to the Internet users, but the apps will not be manageable through the Panel, and you
will not be able to install new apps to the httpsdocs directory.
In such a case, if you have the necessary technical skills, you can do the following:
1. Back up all content from the httpsdocs directory and save it to another location.
Do not move the files to httpdocs yet.
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2. Back up databases used by applications installed in httpsdocs directory. You can
do this with the help of the mysqldump utility.
3. Remove applications from the httpsdocs directory.
4. Switch off the compatibility mode through the Panel (at Websites & Domains tab >
domain name).
5. Reinstall the required applications.
6. Upload the data you backed up on the step 1 to the httpdocs directory.
7. Restore the applications' databases by importing them to the MySQL database
server.
If you are an inexperienced user, we recommend that you leave the previously installed
applications and uploaded content in the httpsdocs directory, and host new
applications on other websites. If you need to install apps on the site operating in
compatibility mode, you can install them to the httpdocs (http://) location on that site.

CHAPTER 2

Changing Your Password and Contact
Information
¾ To change your password for access to Control Panel:
1. Click a link with your name at the top of the screen.
2. Type a new password, and click OK.

¾ To change a username or password that you use for connecting to your
webspace:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, select the required
webspace in the Subscription menu at the top of the screen.
2. Click the Websites & Domains tab.
3. Click Web Hosting Settings.
4. Type the new username or password, and click OK.

¾ To change your contact information:
1. Click a link with your name at the top of the screen.
2. Click the Contact Details tab.
3. Update your contact information and click OK.

CHAPTER 3

Viewing and Managing Your Hosting
Package
When you subscribe to hosting services, a user account is created in the Panel to allow
you to manage your websites and mailboxes on your own.
You can view the following information about your account:


Current subscriptions to service plans.
You can be subscribed to a number of service plans at once, and, therefore, can
have several subscriptions associated with your account. If a billing system is
connected to the Panel, then you can also purchase additional subscriptions,
upgrade or downgrade them, and pay your invoices.



Allocated and consumed resources.



Hosting features available for your websites.



Operations you can perform in your Panel.



Account balance, unpaid invoices, and monthly fee for your hosting package.

Viewing Account Information
¾ To view the information about your account and your current
subscriptions:
1. Click the Account tab.
A list of your current subscriptions is shown.

2. If the billing system is integrated with the Panel, then the following
information is shown:


Account credit balance. This is how much money is available in your billing
account.



Due invoices balance. This is how much money you owe to your provider. Here,
you can pay all invoices at once by clicking Pay All Outstanding Invoices, or pay
one of invoices by clicking a Pay Now link in the list titled Latest Outstanding
Invoices. You can also view all invoices by clicking the link Show all invoices, or
print an invoice by clicking an invoice number and then clicking Print.



Latest to-do items. This shows reminders from the system about actions you need
to take.



List of all your subscriptions. You can use links in the list to perform the
following operations:


View subscription properties by clicking a link with subscription name.
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Select a subscription that you want to manage through the Control Panel by
clicking the corresponding link Switch to Subscription.



Order an SSL certificate for a site by clicking Request SSL Certificate. This
operation is described in the section Ordering SSL Certificates Through the
Billing Panel (on page 63).



View properties of already ordered SSL certificates by clicking Show
Certificate Info.



View or change domain information, contact information, and DNS settings
specified at a registrar's site, by clicking Show Domain Info. These operations
are described in the section Managing Domain DNS Settings and
Registration Information Through the Billing Panel (on page 54).

3. To view detailed information about resource allotments, available
hosting options, and permissions for operations, click a subscription's
name.
4. Do any of the following:


To view a list of allocated and consumed resources, click the Resources tab.



To view a list of hosting features available for your account, click the Hosting
Options tab.



To view a list of operations that you can perform in your Hosting Panel, click the
Permissions tab.

Information About Your Account and
Subscriptions
The following subscription properties are shown in the Panel at the Account tab >
<subscription name>:


Subscription name. Each subscription in the Panel is referred by a domain name of
the first website created under that subscription.



Plan name. Name of the service plan to which you are subscribed.



Setup date. The date when the subscription was activated.



Price. This is a price of your hosting package stated for the subscription term.
Depending on your provider's policy and your subscription term, it can show a price
per one month, several months, or one year.



Latest renewal date. This is shown if a billing system is integrated with your Control
Panel. This indicates the last time when the subscription was prolonged and a new
term was started.



Next renewal date. This is shown if a billing system is integrated with your Control
Panel. This indicates the date when the subscription needs to be prolonged.
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Status. This is shown if a billing system is integrated with your Control Panel. A
subscription can be in several statuses, and the most common of them are active,
pending, and failed. If a subscription is in the active status, then you can work with
your hosting account. If it is in the pending status, then you need to wait for some
time before you can start working with it. If it is in the failed status, then you need to
contact your hosting service provider for assistance.

Allocated and Consumed Resources
If you are subscribed to a number of service plans at once, then you have several
subscriptions. For each subscription, the following types of allocated resources are
listed in the Panel at the Account tab > subscription name > Resources tab:


Disk space. This is the total amount of disk space allocated to your account with
subscription. This amount includes all data related to your websites, e-mail
accounts, applications, backups, and log files.



Traffic. This is the total amount of data in megabytes that can be transferred
monthly from all your websites.



Domains. This is the number of websites that can have separate second-level
domain names, such as, for example, example.com.
For information about setting up websites, refer to the sections Setting Up Your
First Website (on page 22) and Adding More Websites (on page 35).



Subdomains. This is the number of additional websites that can have third-level
domain names, such as, for example, news.example.com.
For information about setting up subdomains, refer to the section Adding
Subdomains (on page 37).



Domain aliases. This is the number of additional domain names that can be set up to
point to one of your sites. For example, example.fr and example.de can both point
to example.com.
For information about setting up domain aliases, refer to the section Setting Up
Additional Domain Names for a Site (on page 77).



Mailboxes. This is the number of mailboxes that can be created under all your
websites.
For information about creating mailboxes, refer to the chapter Using E-mail
Services (on page 113).



Mailbox size. This is the amount of disk space that can be occupied by a mailbox.



Total mailboxes quota. This is the total amount of disk space that can be used by all
mailboxes under all your domains. This option is available only on Windows-based
hosting accounts.



Mailing lists. This is the total number of mailing lists that can be set up under all your
websites. Note that there are mailing lists and mail groups, which serve the same
purpose, but are slightly different in functionality. Mailing lists support archiving and
pre-moderation of messages, while mail groups can only be used for sending one
message to a number of recipients at once.
For information about setting up and using mailing lists, refer to the section Setting
Up Mailing Lists (on page 138).



Additional FTP accounts. This is the number of FTP accounts that can be set up for
accessing the webspace, in addition to the main FTP account that was created
when your subscription was activated.
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For information about setting up FTP accounts, refer to the sections Changing
Username and Password for Access to Webspace over FTP (on page 42) and
Adding FTP Accounts for Collaboration on Web Content (on page 43).


Databases (Linux hosting). This is the number of databases that can be hosted for all
your websites. Databases are a standard means of organizing data storage that
allows dynamic websites, web applications, and their users to store, search, and
retrieve information.
For information about working with databases, refer to the section Deploying
Databases (on page 66).



MySQL databases and Microsoft SQL Server databases (Windows hosting). This is the
maximum number of MySQL and Microsoft SQL Server databases respectively that
can be created on the Panel database servers and used by the subscription's
websites.



MySQL databases quota and Microsoft SQL databases quota (Windows hosting). This is
the maximum amount of disk space (in megabytes) that the subscription's MySQL
and Microsoft SQL Server databases respectively can occupy.



Java applications. This is the number of Java applications packaged in WAR format
that you can install on your sites.



Sites published with SiteBuilder. This is the number of sites that you can create and
publish using SiteBuilder, if SiteBuilder option is included in your hosting package.



Mobile sites.This is the total number of websites that you can host with the UNITY
Mobile online service, which optimizes sites for viewing on mobile devices.



Web users. This is the number of user accounts that you can create for hosting web
pages for other users under your domains.



FrontPage accounts. This is the number of Microsoft FrontPage user accounts that
you can create for collaboration on site content using FrontPage. This option is
available only for Windows-based hosting accounts.



Shared SSL links. This is the number of websites that you can secure with an SSL
certificate shared by your provider. This option is available only for Windows-based
hosting accounts.



ODBC DSN connections. This is the number of connections to external databases that
you can create for web applications running on your hosting account. This option is
available only for Windows-based hosting accounts.



ColdFusion DSN connections. This is the number of connections to external databases
that you can create for web applications written in Adobe ColdFusion, which are
running on your hosting account. This option is available only for Windows-based
hosting accounts.

Hosting Features Available for Your Websites
Depending on your service plan, the following hosting features may be available for
your websites (listed at the Account tab > subscription name > Hosting Options tab):


SSL support. This allows you to secure connections to websites with SSL encryption.
For information about securing sites with SSL, refer to the section Securing
Connections to Websites with SSL (on page 60).



Web statistics. This allows you to view website visitor statistics presented in
diagrams and charts.
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For information about viewing website visits statistics, refer to the section Viewing
Statistics and Log Files (on page 101).


Custom error documents. This allows you to create custom HTML pages and
configure web server to show them instead of typical error messages, such as 404
Not Found.
For information about setting up custom error documents, refer to the section
Setting Up Custom Error Documents (on page 90).



Support for programming and scripting languages, such as PHP, CGI, Perl, Python,
Microsoft ASP, ASP.NET, Adobe ColdFusion, SSI.



Microsoft FrontPage support and Microsoft FrontPage over SSL support. These allow you
to use Microsoft FrontPage to create and edit website content. These options are
available only for Windows-based hosting accounts.



Remote Microsoft FrontPage authoring (Windows hosting). This allows you to use
Microsoft FrontPage to create and edit website content directly on the server. This
option is available only for Windows-based hosting accounts.



Dedicated IIS application pool (Windows hosting). This provides isolation and improved
stability for web applications working on sites.



Additional write/modify permissions (Windows hosting). This option allows the web
applications to use a file-based database (like Jet) located in the root of httpdocs
folder.



Allow web users to use scripts. This allows scripting at web pages available at URLs
like http://example.com/~<username>/<webpage>, where <username> refers to a
web user. Web users are individuals who do not need their own domain names.
This service is popular with educational institutions that host non-commercial
personal pages of their students and staff.

Operations You Can Perform in Your Panel
The following is a list of permissions for operations that you can perform in your Panel
(shown at the Account tab > subscription name > Permissions tab):


DNS zone management. Manage resource records in the DNS zones of websites.
DNS stands for Domain Name System. It is a service that enables web browsers to
locate websites by domain names.
For information about configuring DNS settings for your websites, refer to the
section Managing DNS Settings for Domains (on page 49).



Hosting settings management. Manage web hosting settings, such as support for
scripting languages.



PHP safe mode management. This option is available only for Linux-based hosting
accounts. It allows to switch PHP safe mode on or off for websites. Safe mode is a
security restriction that does not allow scripts written in PHP to perform potentially
dangerous operations on the server. You might need to switch off the safe mode for
PHP if you use some web applications written in PHP and they do not function
properly.



Management of access to the server over SSH and Management of access to the server over
Remote Desktop. Securely upload web content to the server through Secure Shell
(Linux hosting) or a Remote Desktop connection (Windows hosting).
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Anonymous FTP management. Set up a folder on the server which should be
accessible to the Internet users over FTP protocol. This folder can have an address
like, for example, ftp://downloads.example.com. This feature is called anonymous
FTP because the users will not need to specify a username and password to
browse, download, or upload files.
For information about setting up FTP folder with unrestricted access, refer to the
section Setting Up an FTP Directory Available to All Internet Users Without
Authorization (on page 56).



Scheduler management. Schedule execution of programs or scripts in the server's
operating system.
For information about scheduling tasks, refer to the section Scheduling Tasks (on
page 95).



Spam filter management. Set custom settings for protection from unsolicited
commercial e-mail, also known as spam.
For information about setting up spam filtering, refer to the section Protecting
Mailboxes from Spam.



Antivirus management. Set custom settings for protection from viruses and other
malicious software that spreads itself through e-mail.
For information about setting up virus protection, refer to the section Protecting
Mailboxes from Viruses.



Data backup and restoration using the server repository. Use the backup and restore
functions of the Panel to back up and restore websites, mail accounts, settings, and
keep your backup files on the server.
For information about backing up and restoring data, refer to the chapter Backing
Up and Restoring Data (on page 103).



Data backup and restoration using a personal FTP repository. Use the backup and restore
functions of the Panel to back up and restore websites, mail accounts, settings, and
save your backup files to an FTP folder on another server.
For information about backing up and restoring data, refer to the chapter Backing
Up and Restoring Data (on page 103).



Web statistics management. Set custom preferences for visitor statistics reports.
For information about configuring and viewing website visitor statistics, refer to the
section Viewing Statistics and Log Files (on page 101).



Log rotation management. Set custom preferences for recycling (rotation) of web
server logs. Web server records information about connections to your sites and
errors occurred on attempts to retrieve missing files. You can use these log files for
website debugging purposes.
For information about working with web server access logs, refer to the section
Working with Log Files (on page 102).



Access to Application Catalog. View and install applications on websites. For
information about installing applications, refer to the section Installing Applications
(on page 31).



Setup of potentially insecure web scripting options that override provider's policy. This
allows you to override the hosting security policy, if it is applied by the provider.



Domain creation. Set up and manage new websites.
For information about setting up websites, refer to the sections Setting Up Your
First Website (on page 22) and Adding More Websites (on page 35).
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Subdomains management. Set up and manage new websites with addresses like
forum.example.com.
For information about setting up subdomains, refer to the section Adding
Subdomains (on page 37).



Domain aliases management. Set up and manage additional domain names for a site.
For information about setting up domain aliases, refer to the chapter Setting Up
Additional Domain Names for a Site (on page 77).



Additional FTP accounts management. Set up and manage additional FTP accounts. To
enable collaboration on website content, you can set up FTP accounts for other
users and specify which directories of the site should be accessible to them.
For information about setting up FTP accounts, refer to the section Adding FTP
Accounts for Collaboration on Web Content (on page 43).



Java applications management. Install and manage Java applications distributed in
WAR archives and obtained separately from third-party vendors or application
developers.
For information about installing Java applications, refer to the section Installing Java
Applications.



Mailing lists management. Set up and manage mailing lists.
For information about setting up and using mailing lists, refer to the section Using
Mailing Lists.



Hosting performance settings management. Limit the bandwidth and number of
connections to websites.
For information about restricting bandwidth usage for sites, refer to the section
Limiting Bandwidth Use and Number of Connections to Websites (on page 71).



IIS application pool management. Set custom preferences for IIS application pool
(available only on Windows-based hosting accounts).
For information about setting up IIS application pool, refer to the section Setting Up
and Managing Dedicated IIS Application Pool for Your Websites (on page 72).



Additional write/modify permissions management. Set additional write/modify
permissions for websites that use file-based databases (available only on Windowsbased hosting accounts).



Shared SSL management. Secure connections to your sites with SSL protection by
using an SSL certificate shared by your provider.
For more information, refer to the section Using SSL Certificate Shared by Another
Domain (on page 65).



Hard disk quota assignment. Adjust hard quotas on disk space if that is supported by
your hosting account.



Database server selection. Select a database server for creating databases, if multiple
database servers are available.

In this chapter:
Viewing Your Account Balance and Paying for Services .................................... 18
Upgrading, Downgrading, and Purchasing Additional Subscriptions .................. 19
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Viewing Your Account Balance and
Paying for Services
The operations described below are available if your Control Panel is integrated with a
billing system.

¾ To view your account balance and pay for hosting services:
1. Click the Account tab.
2. The following information is shown:


Account credit balance. This is how much money is available in your account.



Due invoices balance. This is how much money you owe to your provider. Here,
you can pay all invoices at once by clicking Pay All Outstanding Invoices, or pay
one of invoices by clicking a Pay Now link in the list titled Latest Outstanding
Invoices.



Latest to-do items. This shows reminders from the system about actions you
need to take.



List of all your subscriptions. You can use links in the list to perform the
following operations:


To view subscription properties, click a link with subscription name.



To select a subscription that you want to manage through the Control Panel,
click the corresponding link Switch to Subscription.



To order an SSL certificate for a site, click Order a Certificate. For more
information about this operation, see the section Ordering SSL Certificates
through the Billing Panel (on page 63).



To view properties of already ordered SSL certificates, click Show Certificate
Info.



To view or change domain information, contact information, and DNS
settings specified at a registrar's site, click Show Domain Info. For more
information about these operations, see the section Managing Domain DNS
Settings and Registration Information through the Billing Panel (on page 54).

¾ To choose a payment method that you would like to use for paying for
services:
1. Go to the Account tab > Billing Accounts.
A record about the payment method that you used for purchasing the services for
the first time is shown.

2. Do any of the following:


To view or change settings for a billing account, click the corresponding link in
the Billing account name column, specify the information about your bank card or
account, and select the subscriptions that should be paid by it. Click OK.
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To add a new billing account, click Add New Billing Account, select the payment
method, click Next, specify the required information about your bank card or
account, and select the subscriptions that should be paid by it. Click OK.



To remove a billing account, click the corresponding Remove link.
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Upgrading, Downgrading, and Purchasing
Additional Subscriptions
The operations described below are available if your Control Panel is integrated with a
billing system.

¾ To add more resources to your subscription or upgrade to another service
plan:
1. Click the Account tab.
2. In the list of subscriptions, locate the subscription that you want to
upgrade to another service plan, and click a link with the currently used
plan's name.
3. Click Upgrade.
If there is no Upgrade link, then it means that you cannot upgrade to another hosting
plan from your Control Panel, and you need to contact your provider.

4. Do any of the following:


To add resources to your subscription without upgrading to another plan, select
the options you would like to add and click Adjust Add-ons.



To upgrade to another service plan, click Order Upgrade.

¾ To reduce the amounts of resources or downgrade to another service
plan:
1. Click the Account tab.
2. In the list of subscriptions, locate the subscription that you want to
downgrade to another service plan, and click a link with the currently
used plan's name.
3. Click Downgrade.
If there is no Downgrade link, then it means that you cannot downgrade to another
hosting plan from your Control Panel, and you need to contact your provider.

4. Do any of the following:


To reduce the amounts of allocated resources without downgrading to another
plan, select the options you would like to reduce and click Adjust Add-ons.
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To downgrade to another service plan, click Order Downgrade.

¾ To purchase an additional subscription for your account:
1. Go to the Account tab.
2. In the list of subscriptions, click the Add Subscription link.
3. Select the hosting plan to which you want to subscribe, and click Buy
Now. Follow the instructions on the screen to complete the order.

CHAPTER 4

Hosting and Managing Websites
This chapter describes how to set up websites and configure web hosting services.
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Setting Up Your First Website
When your hosting account was activated, the hosting server was configured to
accommodate one new website and associate that website with the second-level domain
name that you specified when you ordered the hosting package.
You can now perform the following essential steps to get your site online:
Step 1: Review and change hosting settings for your website (on page 23). This step is
optional and the settings may not be changeable due to provider's policy.


View and select the scripting languages that should be supported for the website.



Select web statistics program that will be used for creating graphical reports for the
website.



Select a directory on the server that will be used for storing website files and
directories, which is called a document root.

Step 2: Add web pages, text, graphics, and useful applications to the website (on page 26):


Open the Panel's built-in SiteBuilder and fill your site with content within a few minutes
(on page 26).



Use web design software of your choice to create website content on your local
computer, and then upload it to the server over FTP (on page 27). You can set up a
number of additional FTP accounts (on page 43) if you need to collaborate with other
people on site content.



Open the Panel's built-in file manager to manually create, edit, or remove site files
and directories (on page 27). This method is convenient if you are comfortable with
HTML markup and need to make quick changes to the source code of web pages.



Install applications on website (on page 31): add content management systems, photo
galleries, shopping carts, blogging platforms, forums, and many more.

Step 3: Preview the site in your browser (on page 33).
Step 4: Submit the site to search engines to ensure traffic to the site (on page 34).
For a comprehensive list of hosting features and services that you can set up for your
websites through the Panel, refer to the section Using Web Hosting Features Available for
Your Account (on page 41).

In this section:
Step 1: Reviewing and Changing Hosting Settings ............................................. 23
Step 2: Filling Website with Content.................................................................... 26
Step 3: Previewing Your Site............................................................................... 33
Step 4: Submitting Website to Search Engines................................................... 34
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Step 1: Reviewing and Changing Hosting Settings
¾ If you want to review the hosting settings or select the hosting features and
scripting languages that should be supported on your site:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the webspace where the website is hosted.
2. Click the Websites & Domains tab.
3. In the list of websites at the bottom of the screen, click the website address.
4. Review or change the following hosting settings and options:


Hosting type. The type of hosting configuration selected by default is website hosting,
which means that the website is hosted on this server. You can also choose to
redirect visitors to another website (this setup is also known as web forwarding);
switch off web hosting service if you need to host only mailboxes and mailing lists
under that domain; or suspend the website and all mailboxes and mailing lists hosted
under the website's domain name.


If you want to redirect visitors to another site, click the Change link, select the
Forwarding option, type the destination site address, select the forwarding scheme,
and click OK.



If you want to switch off web service and use only e-mail services under that
domain, click the Change link, select the No web hosting option, and click OK.



If you want to suspend the website and all services associated with it, including
mail, click the Suspend link. When you need to bring that domain or website back
online, return to the Websites & Domains tab > domain name, and click the Activate
link.



Document root. The location of the directory where all files and subdirectories of the site
will be kept. You can use the default directory called httpdocs or specify another
directory.



Enable SSL support. Secure Sockets Layer encryption is generally used for protecting
transfer of sensitive data during online transactions on e-commerce websites that run
on dedicated IP addresses. SSL certificates that participate in the encryption process
are usually applied to a single domain name on a single IP address, therefore, each
site that needs SSL protection must be hosted on a dedicated IP address. An
exception to this is subdomains, which you can protect with a wildcard certificate.
Installing an SSL certificate on a web server that hosts several websites with different
domain names on a single IP address is technically possible, however, it is not
recommended: the encryption will be provided, but users will get warning messages
on attempt to connect to the secure site. To allow SSL encryption for the website,
select the Enable SSL support checkbox.
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Scripting languages. Specify which of the following programming and scripting
languages should be supported by the web server: Active Server Pages (ASP),
Microsoft ASP.NET, Server Side Includes (SSI), PHP hypertext preprocessor (PHP),
Common Gateway Interface (CGI), Fast Common Gateway Interface (FastCGI), Perl
and Python. By default, PHP is configured to operate in safe mode, with functional
restrictions that strengthen hosting security. To learn more about PHP safe mode,
refer to http://php.net/features.safe-mode.
To learn more about adjustable PHP settings, see the section PHP Settings (on page
25).



Microsoft FrontPage settings. Microsoft FrontPage is a popular website authoring tool. To
enable content creation and publishing through Microsoft FrontPage, select the
options Microsoft FrontPage support, Microsoft FrontPage over SSL support, and Remote
FrontPage authoring allowed.



Web statistics. Select the web statistics software that you want to use for viewing
graphical reports and charts on website visitors. Also, select the corresponding
checkbox if you want to be able to access the statistical reports by visiting the
password-protected directory http://your-website/plesk-stat/webstat.



Custom error documents. When visitors coming to a site request pages that the web
server cannot find, the web server generates and displays a standard HTML page
with an error message. If you want to create your own error pages and use them on
the web server, select the Custom error documents checkbox.



Additional write and modify permissions (available only for Windows hosting). This option
is required if web applications on the site will be using a file-based database (like Jet)
located in the root of httpdocs directory. Note that selecting this option will seriously
compromise the website security.

5. When finished with viewing or changing hosting settings, click OK.
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PHP Settings
You can adjust the following PHP settings:






PHP handler type.


ISAPI (only on Windows). This mode uses less server resources, but a website is
isolated only if it is operating in a dedicated IIS application pool.



Apache module (only on Unix). This mode uses less server resources, but it is the least
secure option. A site is isolated only if PHP safe mode is switched on.



FastCGI application. This mode is faster than CGI, but consumes more memory.
Provides site isolation.



CGI application. This is the slowest mode of operation, but it uses the least amount of
memory.

PHP safe mode.


Switching on PHP safe mode isolates sites, but some applications might not work
because of it.



Switching off PHP safe mode is recommended to ensure stable work of most
applications, but site isolation will not be provided if Apache module is selected as the
PHP handler type.

PHP version (only on Windows).


Version 4.x is outdated, you should use it only if you need to host some old PHP
application versions.



Version 5.x is current and its use is recommended.
Note: When dedicated IIS application pool on Windows is enabled for a site, site
isolation means that a site cannot interfere with other sites and other sites cannot
interfere with it. In all other cases, site isolation implies only that a site cannot
interfere with others, but other sites that are not isolated can interfere with it.
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Step 2: Filling Website with Content
If your hosting plan provides website creation and management service using SiteBuilder,
you can create and publish sites using it. Or you can create your site content (web pages,
scripts and graphic files that compose your site) on your home or office computer and then
publish it to the server in any of the following ways:


Through an FTP connection (most common and easiest way).



Through the Control Panel's file manager.



Through a Secure Shell connection (only for users of Linux and FreeBSD operating
systems).



Through Adobe Dreamweaver or Microsoft FrontPage software (only for users of
Microsoft Windows operating systems).

In this section:
Creating Websites Using SiteBuilder .................................................................. 26
Uploading Website Files over FTP ..................................................................... 27
Using the Panel's File Manager for Working with Files and Directories ............. 27
Installing Applications ......................................................................................... 31

Creating Websites Using SiteBuilder
You can create and publish websites using SiteBuilder, if this option is provided with your
hosting service.
SiteBuilder is a great tool that enables users to create professionally looking sites without
any knowledge of HTML markup or graphic design skills. Just pick a suitable page design
and content template, add your text to pages, and publish the site.

¾ To start creating a website using SiteBuilder:
1. Go to either the Home tab or the Websites & Domains tab, and click Launch
SiteBuilder.
If you have only one domain name configured, SiteBuilder will open in a new browser
window or tab.

2. If you have several domain names, click the corresponding link Edit in
SiteBuilder. The SiteBuilder wizard will open in a new browser window or tab.

Hosting and Managing Websites

27

Uploading Website Files over FTP
¾ To publish website through FTP:
1. Connect to your webspace on the server with an FTP client program, using
your FTP account username and password.
You can change your username and password in the Panel at the Websites & Domains tab
> Web Hosting Settings.
The FTP address should be ftp://your-domain-name.com, where your-domain-name.com
is your site's Internet address.
Enable the passive mode if you are behind a firewall.

2. Upload the files and directories of your site to the httpdocs directory. If you
use CGI scripts, place them into the cgi-bin directory.
3. Close your FTP session.
You can also set up additional FTP accounts if you need to collaborate on website content
with other users. For information, see the section Adding FTP Accounts for Collaboration on
Web Content (on page 43).

Using the Panel's File Manager for Working with Files and
Directories
¾ To upload files through the Panel's file manager:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, select the required
webspace in the Subscription menu at the top of the screen.
2. Click the Websites & Domains tab.
3. Click File Manager.
4. Create or upload files and directories.
Place the files and directories of your site to the httpdocs directory. If you use CGI
scripts, place them into the cgi-bin directory.


To upload a file from your computer, click Add New File, click the Browse button to
locate the file, or specify the path to its location in the Path to file box, and then click
OK.



To create a new directory within your current location, click Add New Directory.



To create new files in the required directory, click Add New File, select the Create a file
option, specify the file name, select the Use html template checkbox, if you want file
manager to insert some basic HTML tags into the new file, and click OK. A page will
open allowing you to enter the content or HTML-formatted source of a new file. After
you finished, click OK.
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When you upload web content through File Manager or FTP, the Panel automatically sets
the appropriate access permissions for files and directories. On Linux-based servers, the
permissions are represented as three sets of symbols, for example, 'rwx rwx r--'. The first set
tells what the owner of the file or directory can do with it; the second tells what the user
group, the file or directory belongs to, can do with the file or directory; the third set indicates
what other users (the rest of the world, that is, Internet users visiting a site) can do with the
file or directory. R means the permission to read the file or directory, W means the
permission to write to the file or directory, and X means the permission to execute the file or
look inside the directory.
To modify permissions for a file or directory on a Linux-based hosting account, click a
hyperlink representing the set of permissions in the Permissions column. If you use a
Windows-based hosting account, click the icon . Modify the permissions as desired and
click OK.
To edit the source code of a file, click

.

To edit the Web page in the built-in visual editor (available only to users of Microsoft Internet
Explorer), click . When editing an HTML file, the Panel opens internal WYSIWYG editor by
default. If you want to edit the source code of the HTML file, click HTML. To return back to
WYSIWYG mode, click Design.
To view the file, click

.

To rename a file or directory, click

. Type in a new name and click OK.

To copy or move a file or directory to another location, select the required file or directory
using the appropriate checkbox, and click Copy/Move. Specify the destination for the file or
directory to be copied or renamed to, then click Copy to copy, or Move to move it.
To update the file or directory creation date, click Change Timestamp. The time stamp will be
updated with the current local time.
To remove a file or directory, select the corresponding checkbox, and click Remove. Confirm
removal and click OK.

In this section:
Setting File and Directory Access Permissions (Linux Hosting) .......................... 29
Setting File and Directory Access Permissions (Windows Hosting) .................... 29

Hosting and Managing Websites

29

Setting File and Directory Access Permissions (Linux Hosting)
¾ To review or change the permissions set for files and directories:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, select the required
webspace in the Subscription menu at the top of the screen.
2. Click the Websites & Domains tab.
3. Click File Manager.
The permissions set for files and directories are shown in the Permissions column. They
are represented as three sets of symbols, for example, 'rwx rwx r--'. The first set tells
what the owner of the file or directory can do with it; the second tells what the user group,
the file or directory belongs to, can do with the file or directory; the third set indicates what
other users (the rest of the world, that is, Internet users visiting a site) can do with the file
or directory. R means the permission to read the file or directory, W means the
permission to write to the file or directory, and X means the permission to execute the file
or look inside the directory.

4. Locate the file or directory for which you want to modify permissions and
click a hyperlink in the Permissions column.
5. Modify the permissions as desired and click OK.

Setting File and Directory Access Permissions (Windows Hosting)
¾ To set access permissions for a file or directory:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > File Manager.
3. Locate the file or directory for which you want to set access permissions, and
click the corresponding icon .
4. Do the following:


To make the file or folder inherit permissions from a parent folder (if it does not),
select the checkbox Allow inheritable permissions from the parent to propagate to this object
and all child objects. Include these with entries explicitly defined here.



To make the files and folders, which are contained in this folder, inherit the folder
permissions you define, select the checkbox Replace permission entries on all child objects
with entries shown here that apply to child objects.



To change or remove permissions from a group or a user, click the required name in
the Group or user names list. If the group or user is not listed in the Group or user names
list, select the required user or group name from the menu located above the list and
click : the user/group appears in the list. Select it.
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To allow or deny permissions to a selected group/user, select the Allow or Deny
checkboxes corresponding to permissions listed under Permissions for <user/group
name>. If the checkboxes in Allow or Deny columns are shown in grey, it means that the
corresponding permissions are inherited from a parent folder.


To deny the permissions, which are inherited from a parent object as allowed, select
the required checkboxes under Deny. This will override inherited permissions for this
file/folder.



To allow the permissions, which are inherited from a parent object as denied, clear the
Allow inheritable permissions from the parent to propagate to this object and all child objects.
Include these with entries explicitly defined here checkbox: this removes the inherited
permissions. Then select the required checkboxes under Allow and Deny.



To remove access permissions from a group or user, select the required name in the
next to it.
Group or user names list and click the icon

5. If you need advanced fine-tuning of permissions, click the Advanced button,
and do the following:


To create a permission entry for a group or user, select the required name from the
Group or user names list and click .



To set or change file/folder permissions for a group or user, select the required name
from the Group or user names list, select the required Allow and Deny checkboxes
corresponding to permissions listed under Permissions for <user/group name>.



To remove a permission entry for a group or user, select the required name from the
Group or user names list and click .



To make child objects of a folder inherit its permissions defined under Permissions for
<user/group name>, select the Replace permission entries on all child objects with entries
shown here that apply to child objects checkbox, and select checkboxes in the Apply to list
which correspond to the objects that must inherit the permissions.

6. Click OK.

Hosting and Managing Websites

31

Installing Applications
Instead of manually creating files, writing the code, and developing design for your website,
you can install web applications that will accomplish most of these tasks for you. You can
use the applications to add features to your site, such as blog, photo gallery, online store, or
you can base your site entirely on a single application, such as Wordpress.
You can install these applications by using the following links in your Control Panel:


Applications tab > Featured Applications. This provides links for installing the most popular
applications.



Applications tab > All Available Applications. This shows all applications available for your
account.

¾ To install an application:
1. Click the Applications tab.
2. Click All Available Applications.
3. Use the links to browse within the application categories and groups, or use
the search function to find the application you want to install.
4. Click the corresponding Install button.
5. Read the license agreement for the application. If you accept the terms of
the license agreement, select the I accept the terms of the license agreement
checkbox, and click Next >.
6. Specify the following installation settings:


Path to installation directory. Select the website where you want to install the
application, and type the desired directory name, if you want to install it into a specific
directory.



Application administrator's username and password. If you are going to administer the
application on your own, leave your name selected. If you want to delegate
administration tasks to someone else, select the option Use administrative credentials not
connected to any particular user and type the username and password.



Software license activation code. This information is required only for the paid
applications.



Other settings that may be required by the application. To review or set these settings,
click the Show All Settings link.

7. Click Install.
If you created user accounts in the Panel (on page 140) and want to allow the users to
manage installed applications, modify the role that is assigned to their accounts, or create a
new user role and then assign it to the users:

1. Click the Users tab in the top navigation area.
2. Click the User Roles tab.
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3. Click Create User Role to create a new user role, or select an existing role from
the list by clicking the role name.
4. Under the Access to applications group, locate the application you need, and
select the corresponding Granted option.
5. Click OK.
Now all users who are assigned this role will be able to access this application by clicking
the corresponding shortcuts in their Panels (on the Home tab), and specifying their user
account names and passwords.

6. If you decided to create a new role and assign it to the existing users who
need access to the application, go to Users > User Accounts, click the user's
name you need, select the newly created role in the User role menu, and click
OK.

¾ To upload a new license key (or activation code) for a paid application:
1. Click the Applications tab.
2. In the left frame, click Manage Installed Applications.
3. Click the application name.
4. Click License Key.
5. Specify the activation code or upload the license key.
6. Click OK.

¾ To update or upgrade an application:
1. Click the Applications tab.
2. In the left frame, click Manage Installed Applications. If there are available
updates, an Update available link will appear under the application name.
3. Click the Update available link, and review the changes or features available in
the new version.
4. If you still want to update or upgrade to the new version, click Update Now.

¾ To review or change the application settings:
1. Click the Applications tab.
2. In the left frame, click Manage Installed Applications.
3. Click the application name.
4. Do any of the following:


To review or change the application settings, click Settings.



To view the information about the application, click About.
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¾ To remove an application with all related data:
1. Click the Applications tab.
2. In the left frame, click Manage Installed Applications.
3. Locate the application that you want to remove, and click the corresponding
Uninstall link.
4. To confirm removal, click Yes.

Step 3: Previewing Your Site
After you uploaded website files to the webspace, you can check how it will look in a web
browser, even before the information about the new site has spread in the Domain Name
System.

¾ To preview a site:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, select the required
webspace in the Subscription menu at the top of the screen.
2. Click the Websites & Domains tab.
3. In the list of domain names at the bottom of the screen, locate the website
that you want to preview and click the corresponding icon .
You site will open in a new browser window.
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Step 4: Submitting Website to Search Engines
To gain more visitors and drive traffic to your site after you publish it on the Internet, you
need to submit it to search engines.
To improve your site ranking in search results, consider optimizing web pages:


Include in the text contained in your web pages the frequently searched keyword
phrases, which are relevant to the topic of your site. For example, mention your product
or a topic of your interest several times in the text on a web page.



Add relevant keywords to the <title> and <meta> tags. Some search engines look for
keywords and descriptions in meta tags placed within web pages, and present these
keywords in search results.

For example, if you are selling hosting automation software, then you can include the
following tags in HTML pages of your website:
<HEAD>
<TITLE>Ordering hosting automation software
</TITLE>
<META name="keywords" content="order,hosting,software">
<META name="description" content="Ordering Hosting Automation Software">
</HEAD>

Separate the keywords with a comma without white spaces.
After you optimize the website and publish it to your hosting account, submit it to search
engines, such as Google, Yahoo, Bing, and other engines that you know to be popular in
your country.


To submit a site to Google, visit http://www.google.com/addurl/.



To submit a site to Yahoo, visit https://siteexplorer.search.yahoo.com/submit.



To submit a site to Bing, visit http://www.bing.com/webmaster/SubmitSitePage.aspx.
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Adding More Websites
If your hosting package includes more than one domain name (website), then you can easily
add new sites to the server. Before you start adding a new site that will use a second-level
domain name, like example.com, be sure to register that domain name with your service
provider or another domain name registration authority.
You can set up the following types of site configurations through the Panel:




Website addressed by a second-level domain name. The following services are available for
websites:


A unique Internet address (domain name), like example.com.



Additional domain names (domain aliases).



Subdomains - divisions of a site accessible by easy-to-remember addresses that are
added to the main site, like mail.example.com.



Separate FTP accounts for collaboration on the site content. For every FTP account,
you can specify which directories can be accessed.



Simplified deployment of applications, such as content management systems, photo
galleries, shopping carts, blogging platforms, and many more.



Secure data exchange implemented by SSL protocol. This requires that a site be
hosted on a dedicated IP address, which is not shared among other users and sites.



Mailboxes and mailing lists.

Website or a division of a website addressed by a third-level domain name (subdomain). This is
usually a division of an existing site. It has an Internet address comprising of three parts
separated by dots. The following services are available for subdomains:


Separate document root from the main site. Document root is a directory on the server
where web pages of a site are stored.



Access over FTP for content management.



Simplified deployment of applications.

¾ To host a new website with a second-level domain name:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, select the required
webspace in the Subscription menu at the top of the screen.
2. Click the Websites & Domains tab.
3. Click Add New Domain.
4. Specify the following:
a. In the Domain name box, type the domain name that you have
registered with your service provider or a domain name registration
company.
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b. Under DNS server configuration, select the option Keep master DNS zone on
this server.
c. Under Hosting type, select the Website hosting option.
d. In the Document root box, type the desired location of the directory
where all files and subdirectories of the site will be kept. You can use
the default directory called httpdocs or specify another directory.
5. Click OK.
The new domain name is now shown in the list at the bottom of the screen.

6. If the operation of changing hosting settings is available for your account,
then you can click the domain name of the new website to view or change
the hosting settings, as described in the section Reviewing and Changing
Hosting Settings (on page 23).
You can now start creating your website with SiteBuilder or upload your web content to the
webspace of the new website, as described in the section Filling Website with Content (on
page 26).
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Adding Subdomains
If your hosting package includes subdomains, which are additional third-level domain names,
then you can use them to:


Organize logically the structure of your site.



Host additional websites or parts of a website on the same server without the need to pay
for registration of additional domain names.

An example of using subdomains:
You have a website your-product.com dedicated to promoting and selling your product. For
publishing information related to customer service and online order tracking, you can
organize the subdomain "orders" so that your users will be able to access this information
directly by visiting the Internet address "orders.your-product.com".

¾ To set up a subdomain for a site division or a separate site:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, select the required
webspace in the Subscription menu at the top of the screen.
2. Click the Websites & Domains tab.
3. Click Add New Subdomain.
4. Specify the following:
a. In the Subdomain name box, type the portion of address that will be
added to the domain name of your main site.
b. In the Document root box, type the desired location of the directory
where all files and subdirectories of this site will be kept. You can
use the default directory of the main site, called httpdocs, or specify
another directory.
5. Click OK.
The new subdomain name is now shown in the list at the bottom of the screen.
You can now upload your web content to the subdomains webspace (directory on the
server), as described in the section Uploading Website Files over FTP (on page 27).
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Redirecting Visitors to Another Site
You can set up a new domain name or reconfigure an existing domain name so that it will
redirect visitors to another website.

¾ To add a new domain forwarder:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, select the required
webspace in the Subscription menu at the top of the screen.
2. Click the Websites & Domains tab.
3. Click Add New Domain.
4. Specify the following:
a. In the Domain name box, type the domain name that you have
registered with your service provider or a domain name registration
company.
b. Under DNS server configuration, select the option Keep master DNS zone on
this server.
c. Under Hosting type, select the Forwarding option.
d. In the Destination address box, type the Internet address to which you
want to redirect visitors.
e. Under Forwarding type, select the preferred type of forwarding. With
standard forwarding, a user is redirected to the site and the actual site's
address is shown in the user's browser, so the user always knows
that he or she is redirected to another address. With frame forwarding,
a user is redirected to the site without knowing that the site actually
resides at another location, therefore, frame forwarding should be
preferred.
5. Click OK.

¾ To reconfigure an existing domain and make it a domain forwarder:
1. Go to Websites & Domains tab > domain name.
2. Click the Change link next to the Hosting type field.
3. Specify the following:
a. Under Hosting type, select the Forwarding option.
b. In the Destination address box, type the Internet address to which you
want to redirect visitors.
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c. Under Forwarding type, select the preferred type of forwarding. With
standard forwarding, a user is redirected to the site and the actual site's
address is shown in the user's browser, so the user always knows
that he or she is redirected to another address. With frame forwarding,
a user is redirected to the site without knowing that the site actually
resides at another location, therefore, frame forwarding should be
preferred.
4. Click OK.

Suspending and Activating Websites
When a website is suspended, it becomes inaccessible over the Internet, and e-mail
addresses under the site's domain name stop working.

¾ To suspend a website:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, select the required
webspace in the Subscription menu at the top of the screen.
2. Click the Websites & Domains tab.
3. Click the domain name of the site that you want to suspend.
4. Click the Suspend link next to the Hosting type field.

¾ To activate a website:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, select the required
webspace in the Subscription menu at the top of the screen.
2. Click the Websites & Domains tab.
3. Click the domain name of the site that you want to activate.
4. Click the Activate link next to the Hosting type field.
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Deleting Websites
When you delete a domain name or website from the Panel, all data related to that site are
deleted from the server. The first domain name (website) that was created for your account
cannot be deleted; however, it can be renamed.

¾ To delete a website:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, select the required
webspace in the Subscription menu at the top of the screen.
2. Click the Websites & Domains tab.
3. In the list of domain names, select the domains or subdomains that you want
to remove and click Remove.
4. Confirm removal and click OK.
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Using Web Hosting Features Available for
Your Account
This section describes all hosting-related features, settings, and operations that may be
available for your account.


Change hosting settings for websites (on page 23): select hosting type, programming
languages, switch on support for custom error documents.



Change your username and password used for connecting to your webspace over FTP
and managing files. (on page 42)



Set up additional FTP accounts for managing website content. (on page 43)



Set up additional FrontPage accounts (on page 48) for publishing website content and
change FrontPage settings for websites (on page 45) (on Windows hosting accounts).



Manage DNS zones for domains. (on page 49)



View graphical reports on website visits presented by Webalizer or AWStats programs.
(on page 101)



View web server logs. (on page 101)



Set up a directory within the site, where other users will be able to anonymously
download or upload files through FTP. (on page 56)



Secure connections to website with SSL protection. (on page 60)



Protect website files from direct linking to save your bandwidth (on Windows hosting
accounts). (on page 70)



Protect website from denial-of-service attacks by limiting the number of connections and
bandwidth use. (on page 71)



Back up and restore websites. (on page 103)



Create and manage databases and database users if you use a dynamic website or host
a web application on your account. (on page 66)



Add subdomains - parts of your website with distinct names. (on page 37)



Add alternative domain names (domain aliases) that will point to your website. (on page
77)



Set up virtual directories (on Windows hosting accounts). (on page 79)



Create user accounts for people whose personal web pages you want to host under your
domain name. (on page 75)



Schedule execution of programs or scripts on your hosting account. (on page 95)



Create a website copy optimized for viewing on mobile devices (on page 100).
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Changing Username and Password for Access to
Webspace over FTP
All files and directories related to your sites are kept on the server in a single directory,
commonly referred to as webspace. To connect to the webspace over FTP for uploading,
downloading, and deleting files, you use FTP account username and password.

¾ To change FTP account username or password:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the webspace where the website is hosted.
2. Click the Websites & Domains tab.
3. Click Web Hosting Settings.
4. Type a new username or password.
5. Click OK.
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Adding FTP Accounts for Collaboration on Web Content
If you are working on your website together with someone else or host subdomains for other
users, you might want to create separate FTP accounts for them.

¾ To create an additional FTP account:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Click the Websites & Domains tab.
3. Click FTP Access.
4. On the Additional FTP Accounts tab, click Create Additional FTP Account.
5. Specify the following:


FTP account name. Type an arbitrary name.



Home directory. Select the directory to which the user will be taken when he or she
connects to the FTP account.



FTP password.



Hard disk quota (on Windows hosting). To limit the amount of disk space on the server
that the FTP user can occupy, clear the Unlimited checkbox next to the Hard disk quota
box, and type the amount of disk space in megabytes.



Read permission (on Windows hosting). To allow the FTP user to view the contents of
the home directory and download files from it, select the Read permission checkbox.



Write permission (on Windows hosting). To allow the FTP user to create, view, rename
and delete directories in the home directory, select the Write permission checkbox.
On Window hosting, if you do not grant any permissions, a connection to the FTP
account will be made, but the contents of the home directory will not be shown to the
user.

6. Click OK.

¾ To change the properties of an additional FTP account:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Click the Websites & Domains tab.
3. Click FTP Access.
4. On the Additional FTP Accounts tab, click the required FTP account name in the
list.
5. Make the required changes and click OK.
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¾ To remove an additional FTP account:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Click the Websites & Domains tab.
3. Click FTP Access.
4. On the Additional FTP Accounts tab, select the checkbox corresponding to the
FTP account you want to remove and click Remove.
5. Confirm removal and click OK.
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Publishing Sites with Microsoft FrontPage (Windows
Hosting)
Microsoft FrontPage deals with two kinds of websites: disk-based and server-based. In short,
a disk-based site is a FrontPage website you create on your local hard disk and then later
publish to the server. A server-based site is one you create and work with directly on the
server, without the extra step of publishing. This section provides you with instructions on
publishing only disk-based websites.
You can publish disk-based websites either through FTP or HTTP. If your hosting server is
running FrontPage Server Extensions, you would publish your site over HTTP. For example:
http://your-domain.com/MyWebSite. If your hosting server supports FTP, you would publish
to an FTP location. For example: ftp://ftp.your-domain.com/myFolder.
After publishing, you can manage your site through FrontPage Server Extensions.

¾ To access FrontPage Server Extensions management interface:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Click the Websites & Domains tab.
3. In the Advanced Operations group, click FrontPage.
4. Do either of the following:


To manage a site over HTTP connection, click Frontpage Webadmin.



To manage a site over a secure SSL connection, if SSL support is enabled for the
site, click Frontpage SSL Webadmin.

5. Type your FrontPage administrator’s username and password, and click OK.
For instructions on using FrontPage server extensions, see online help (Frontpage Webadmin >
Help) or visit Microsoft website.
The following FrontPage settings are changeable through the Panel:


The use of Microsoft FrontPage IIS Index Server for building the full-text index of your
website.



SMTP mail server and sender's e-mail address. These options are applicable if you
use FrontPage forms that submit information from your site by e-mail. By default,
SMTP server specified in the domain's DNS zone is used for sending mail. If no
SMTP server is specified in the zone, then FrontPage uses the mail service running
on the server where the domain (site) is hosted.

¾ To change any of these settings:
1. Go to the Websites & Domains tab > FrontPage > Settings.
2. Make the required changes and click OK.
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Publishing from Microsoft FrontPage through FTP
¾ To publish files through FTP:
1. Open your FrontPage program.
2. Open a FrontPage website: open File menu and select the Open Site item.
3. Go to Remote Web site view: click the Web Site tab, and then the Remote Web Site
button at the bottom of the window.
4. Set up your Remote Web Site Properties:


Click the Remote Web Site Properties button in the upper-right corner of the window.



Select FTP as the remote Web server.



In the Remote Web site location box, type your host name (for example, ftp://ftp.yourdomain.com)



In the FTP directory box, type your FTP directory if your hosting company provided one.
Leave it blank if they did not specify one.



Select the Use Passive FTP check box if your computer or network is protected by a
firewall.

5. Click OK to connect to the remote site.
The Remote Web site view will show files that you have in your local and remote sites.

6. Click the Publish Web site button in the lower-right corner of the window.
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Publishing from Microsoft FrontPage through HTTP
¾ To publish files through HTTP on a server that supports FrontPage Server
Extensions:
1. Open your FrontPage program.
2. Open a FrontPage website: open File menu and select the Open Site item.
3. Go to Remote Web site view: click the Web Site tab, and then the Remote Web Site
button at the bottom of the window.
4. Click the Remote Web Site Properties button in the upper-right corner of the
window.
5. On the Remote Web Site tab, under Remote Web server type, click FrontPage or
SharePoint Services.
6. In the Remote Web site location box, type the Internet address, including the
protocol, of the remote website that you want to publish folders and files to,
for example, http://www.your-domain.com, or click Browse to locate the site.
7. Do any of the following:


To use Secure Sockets Layer (SSL) for establishing a secure communications
channel to prevent the interception of critical information, click Encryption connection
required (SSL). To use SSL connections on your web server, the server must be
configured with a security certificate from a recognized certificate authority. If the
server does not support SSL, clear this check box. Otherwise, you will not be able to
publish folders and files to the remote website.



To remove specific types of code from web pages as they are being published, on the
Optimize HTML tab, select the options you want.



To change the default options for publishing, on the Publishing tab, select the options
you want.

8. Click OK to connect to the remote site.
The Remote Web site view will show files that you have in your local and remote sites.

9. Click the Publish Web site button in the lower-right corner of the window.
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Setting Up Additional Microsoft FrontPage Accounts
(Windows Hosting)
If you are using Microsoft FrontPage for collaborating on website content with other users,
then you need to create additional Microsoft FrontPage accounts.

¾ To create an additional Microsoft FrontPage account:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Click the Websites & Domains tab.
3. In the Advanced Operations group, click FrontPage.
4. Click Add New FrontPage Account.
5. Specify the following:


Username and password for the account.



Limit on disk space. If you wish to limit the amount of disk space that can be used by
this account, clear the Unlimited check box and type the desired value in megabytes
into the Hard disk quota box.
When the specified limit is exceeded, the user will not be able to upload more files to
the webspace.

6. Click OK.

¾ To change settings for an additional Microsoft FrontPage account:
1. Go to the Websites & Domains tab > FrontPage.
2. Click the required account name in the list.
3. Adjust the settings as necessary and click OK to save changes.

¾ To remove an additional Microsoft FrontPage account:
1. Go to the Websites & Domains tab > FrontPage.
2. Select the checkbox corresponding to the account you want to remove.
3. Click Remove.
4. Confirm the removal and click OK.
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Managing DNS Settings for Domains
For each new domain name, the Panel automatically creates DNS zone in accordance with
the settings configured by your service provider. The domain names should work fine with
the automatic configuration, however, if you need to perform custom modifications in the
domain name zone, you can do that through your Panel.

¾ To view the resource records in a DNS zone of a domain:
1. Go to the Websites & Domains tab > DNS Settings.
2. If you have several domain names, select the domain name whose DNS
settings you want to manage.
A screen will show all resource records for a given domain.

¾ To add a new resource record to the zone:
1. Go to the Websites & Domains tab > DNS Settings.
2. If you have several domain names, select the domain name whose DNS
settings you want to manage.
3. Click Add Record.
4. Select a resource record type, and specify the appropriate data:


For an NS record, which specifies the domain name of a name server that is
responsible for a DNS zone of a domain, you need to specify the domain name (or a
subdomain), and then the corresponding name server's domain name. If you are
defining an NS record for your main domain, then you should leave the domain name
field empty. If you are defining a name server for a subdomain, then type the
subdomain into the domain name field. After that, type the appropriate name server's
domain name into the name server field. For example: ns1.mynameserver.com.



For an A record, which associates IP addresses with domain names, you need to
specify the domain name and IP address. If you are simply defining an A record for
your main domain, then you should leave the domain name field empty. If you are
defining an A record for a name server, then type ns1 or ns2 into the domain name
field. Then specify the appropriate IP address with which to associate the domain
name.



For a CNAME record, which specifies which subdomains (or domain aliases that look
like subdomains, for example, www) should be associated in the Domain Name
System with the main domain address, you need to type the subdomain name or www
alias, and then, the main domain name.



For an MX record, which specifies the host name of the preferred mail server for the
given domain, you need to specify the mail domain (or subdomain), the domain name
of the mail exchange server responsible for receiving e-mail, and the server's priority.
For the main domain, you would simply leave the available field blank. Then type the
domain name of your mail server. If you are running a remote mail server named
'mail.myhostname.com', then simply type 'mail.myhostname.com' into the Mail
exchange server field. After that, specify its priority: 0 is the highest and 50 is the lowest.
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For a PTR record, which is required for reverse DNS lookup (an IP address is
translated to domain name), you need to enter the IP address/mask, and then type
the appropriate domain name for this IP address to be translated to.



For a TXT record, which is used for specifying arbitrary human-readable text, you can
type an arbitrary text string, or an SPF record.



For an SRV record, which is used for specifying location of services other than mail,
you will need to enter the service name, protocol name, port number, and target host.
Service and protocol names should start with the underscore symbol. You can also
specify the priority of the target host, and relative weight (for records with the same
priority) in the appropriate fields.

4. Click OK, and then click Update.

¾ To modify the properties of a resource record:
1. Go to the Websites & Domains tab > DNS Settings.
2. If you have several domain names, select the domain name whose DNS
settings you want to manage.
3. Click the hyperlink in the Host column corresponding to the resource record
you want to modify.
4. Modify the record as required, click OK, and then click Update.
In addition to the resource records described above, there is also a Start of Authority record.
This record indicates that this DNS name server is responsible for the domain's DNS zone. It
also contains settings that affect propagation of information about the DNS zone in the
Domain Name System.

¾ To modify the entries in the Start of Authority (SOA) record for a domain:
1. Go to the Websites & Domains tab > DNS Settings.
2. If you have several domain names, select the domain name whose DNS
settings you want to manage.
3. Click SOA Record.
4. Specify the required values:


Refresh interval. This is how often the secondary name servers check with the primary
name server to see if any changes have been made to the domain's zone file. The
Panel sets the default value of three hours.



Retry interval. This is the time a secondary server waits before retrying a failed zone
transfer. This time is typically less than the refresh interval. The Panel sets the default
value of one hour.



Expire interval. This is the time before a secondary server stops responding to queries,
after a lapsed refresh interval where the zone was not refreshed or updated. The
Panel sets the default value of one week.



Minimum TTL. This is the time a secondary server should cache a negative response.
The Panel sets the default value of three hours.

Hosting and Managing Websites



51

Default TTL. This is the amount of time that other DNS servers should store the record
in a cache. The Panel sets the default value of one day.

5. Click OK, and then click Update.
Usage of serial number format recommended by IETF and RIPE is mandatory for many
domains registered in some high-level DNS zones, mostly European ones. If your domain is
registered in one of these zones and your registrar refuses your SOA serial number, using
serial number format recommended by IETF and RIPE should resolve this issue.
The Panel-managed servers use UNIX timestamp syntax for configuring DNS zones. UNIX
timestamp is the number of seconds since January 1, 1970 (Unix Epoch). The 32-bit
timestamp will overflow by July 8, 2038.
RIPE recommends using YYYYMMDDNN format, where YYYY is year (four digits), MM is
month (two digits), DD is day of month (two digits) and NN is version per day (two digits).
The YYYYMMDDNN format will not overflow until the year 4294.

¾ To change the Start of Authority (SOA) serial number format to YYYYMMDDNN
for a domain:
1. Go to the Websites & Domains tab > DNS Settings.
2. If you have several domain names, select the domain name whose DNS
settings you want to manage.
3. Click SOA Record.
4. Select the Use serial number format recommended by IETF and RIPE checkbox.
Note: See the sample of SOA serial number generated with the selected format. If the
resulting number is less than the current zone number, the modification may cause
temporary malfunction of DNS for this domain. Zone updates may be invisible to the
Internet users for some time.

5. Click OK, and then click Update.

¾ To remove a resource record from the zone:
1. Go to the Websites & Domains tab > DNS Settings.
2. If you have several domain names, select the domain name whose DNS
settings you want to manage.
3. Select a checkbox corresponding to the record you want to remove.
4. Click Remove.
5. Confirm removal, click OK, and then click Update.

¾ To restore the original zone configuration in accordance with the default DNS
template settings used on the server:
1. Go to the Websites & Domains tab > DNS Settings.
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2. If you have several domain names, select the domain name whose DNS
settings you want to manage.
3. Click Restore Defaults.
4. In the IP address menu, select the IP address to be used for restoring the
zone.
5. Specify whether a www alias is required for the domain.
6. Select the Confirm the restoration of the DNS zone checkbox, and click OK.

¾ To restore the default Start of Authority (SOA) serial number format (UNIX
timestamp) for a domain:
1. Go to the Websites & Domains tab > DNS Settings.
2. If you have several domain names, select the domain name whose DNS
settings you want to manage.
3. Click SOA Record.
4. Clear the Use serial number format recommended by IETF and RIPE
checkbox.
Note: See the sample of SOA serial number generated with the selected format. If the
resulting number is less than the current zone number, the modification may cause
temporary malfunction of DNS for this domain. Zone updates may be invisible to the
Internet users for some time.

5. Click OK, and then click Update.
By default, transfer of DNS zones is allowed only for the name servers designated by NS
records contained within each zone. If you are using a Windows-based hosting account, then
you can change zone transfer settings.

¾ If your domain name registrar requires that you allow transfer for all zones you
serve:
1. Go to the Websites & Domains tab > DNS Settings.
2. If you have several domain names, select the domain name whose DNS
settings you want to manage.
3. Click Zone Transfers. A screen will show all hosts to which DNS zone transfers
for all zones are allowed.
4. Specify the registrar's IP or network address and click Add Network.

In this section:
Serving Websites with External Domain Name Servers...................................... 53
Managing Domain DNS Settings and Registration Information Through the Billing
Panel ................................................................................................................... 54
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Serving Websites with External Domain Name Servers
If you host websites on your hosting account and have a standalone DNS server acting as a
primary (master) name server for your sites, you may want to set up the Panel's DNS server
to function as a secondary (slave) name server.

¾ To make the Panel's DNS server act as a secondary name server:
1. Go to the Websites & Domains tab > DNS Settings.
2. If you have several domain names, select the domain name whose DNS
settings you want to manage.
3. Click Switch DNS Service Mode.
4. Click Add Record.
5. Specify the IP address of the primary (master) DNS server.
6. Click OK, and then click Update.
7. Repeat steps from 2 to 6 for each website that needs to have a secondary
name server on your server.

¾ To make the Panel's DNS server act as a primary for a zone:
1. Go to the Websites & Domains tab > DNS Settings.
2. If you have several domain names, select the domain name whose DNS
settings you want to manage.
3. Click Switch DNS Service Mode.
The original resource records for the zone will be restored.
If you have external primary and secondary name servers that are authoritative for some of
your websites, switch off the Panel's DNS service for each of these sites.

¾ To switch off the Panel's DNS service for a site served by external name
servers:
1. Go to the Websites & Domains tab > DNS Settings.
2. If you have several domain names, select the domain name whose DNS
settings you want to manage.
3. Click Switch Off the DNS Service.
Turning the DNS service off for the zone will refresh the screen, so that only a list of
name servers remains. Note that the listed name server records have no effect on the
system. They are only presented on the screen as clickable links to give you a chance to
validate the configuration of the zone maintained on the external authoritative name
servers.
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4. If you want to validate the configuration of a zone maintained on
authoritative name servers, do the following:
a. Add to the list the entries pointing to the appropriate name servers
that are authoritative for the zone: Click Add Record, specify a name
server, click OK, and then click Update.
b. Repeat the step a for each name server you would like to test. The
records will appear in the list.
c. Click the records that you have just created.
The Panel will retrieve the zone file from remote name servers and will check the
resource records to make sure that domain's resources are properly resolved. The results
will be interpreted and displayed on the screen.

Managing Domain DNS Settings and Registration Information
Through the Billing Panel
If the Control Panel is integrated with a billing system, then the following operations on
domains might be available from the Panel:


Setting a password for access to domain management panel at a registrar's site.



Locking and unlocking domain name for transferring to another provider.



Changing domain registrant and other contact information.



Changing DNS settings for domain zones served by a domain registrar.



Configure automatic renewal of the domain account at the domain name registration
company.

¾ To set a new password for access to your domain management control panel at
a registrar's site:
1. Go to the Account tab.
2. Locate the domain name for which you want to change settings, and click the
link Show Domain Info next to it.
3. Click Change Domain Password.
4. Type a new password and click OK.

¾ To lock or unlock domain name for transferring to another provider:
1. Go to the Account tab.
2. Locate the domain name for which you want to change settings, and click the
link Show Domain Info next to it.
3. Click Change Registrar Lock Setting.
4. To allow domain name transfer, clear the Lock checkbox and click OK.
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¾ To change domain owner's contact, technical, administrative, or billing
information:
1. Go to the Account tab.
2. Locate the domain name for which you want to change settings, and click the
link Show Domain Info next to it.
3. Click Edit Contact Info.
4. Make the necessary changes and click OK.

¾ To change DNS settings for a domain:
1. Go to the Account tab.
2. Locate the domain name for which you want to change settings, and click the
link Show Domain Info next to it.
3. Click Edit DNS Settings.
4. Specify the domain name servers that serve the DNS zone for your website
and IP address of the server where the website is hosted.
5. If the DNS zone of your website is served by your domain name registrar,
then you can also specify other resource records that affect how your
website's services are accessible over the Internet.
6. To save your changes, click OK.

¾ To configure automatic renewal of the domain name:
1. Go to the Account tab.
2. Locate the domain name for which you want to change settings, and click the
link Show Domain Info next to it.
3. Click Automatic Domain Renewal.
4. To allow auto renewal of the domain registration, select the Turn on auto
renewal checkbox and click OK.
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Setting Up an FTP Directory Available to All Internet Users
Without Authorization
If your site is hosted on a dedicated IP address (not shared by other users or sites), you can
set up a directory within the site, where other users will be able to anonymously download or
upload files through FTP. Once anonymous FTP is switched on, the users will be able to log
in to the directory at an address like ftp://ftp.your-domain.com with the "anonymous"
username and any password.

¾ To allow anonymous FTP access:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Click the Websites & Domains tab.
3. Click FTP Access.
4. Click the Anonymous FTP tab.
5. Do the following:
a. To activate anonymous FTP service, click Switch On.
b. To set up a welcoming message to be displayed when users log in to
FTP site, select the Display login message checkbox and type the
message text in the input field as desired.
Note that not all FTP clients display welcoming messages.

c. To allow visitors to upload files to the /incoming directory, select
the Allow uploading to incoming directory checkbox.
d. To allow users to create subdirectories in the /incoming directory,
select the Allow creation of directories in the incoming directory checkbox.
e. To allow downloading files from the /incoming directory, select the
Allow downloading from the incoming directory checkbox.
f. To limit the amount of disk space that can be occupied by uploaded
files, clear the Unlimited checkbox corresponding to the Limit disk space
in the incoming directory option, and specify the amount in kilobytes.
This is the hard quota: The users will not be able to add more files to the directory
when the limit is reached.

g. To limit the number of simultaneous connections to the anonymous
FTP server, clear the Unlimited checkbox corresponding to the Limit
number of simultaneous connections option and specify the number of
allowed connections.
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h. To limit the bandwidth for anonymous FTP connections, clear the
Unlimited checkbox corresponding to the Limit download bandwidth for this
virtual FTP domain option and enter the maximum bandwidth in
kilobytes per second.
6. Click OK.

¾ To change settings for anonymous FTP service or switch it off:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Click the Websites & Domains tab.
3. Click FTP Access.
4. Click the Anonymous FTP tab.
5. Perform the operation you need:


Adjust the settings as required and click OK.



To switch off the anonymous FTP service, click Switch Off.
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Restricting Access to Website's Resources with Password
Protection
If you have directories in a site that only authorized users should see, restrict access to these
directories with password protection.

¾ To protect a directory in your site with a password and to specify authorized
users:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Password-protected Directories (in the Advanced
Operations group).
3. Click Add Protected Directory.
4. In the Directory name box, specify the path to the directory that you want to
protect with a password.
This can be any directory existing in the site, for example: /private. If the directory that
you would like to protect has not yet been created, specify the path and the directory
name – the Panel will create it for you.

5. If you are using a Linux-based hosting account, you can also protect your
CGI scripts stored in the cgi-bin directory. To do this, leave '/' in the
Directory name box and select the cgi-bin checkbox.
6. In the Title of the protected area box, type a resource description or a welcoming
message that your users will see when they visit the protected area.
7. Click OK. The directory you specified will be protected.
8. To add authorized users, click Add New User.
9. Specify the login name and password that will be used for accessing the
protected area. The password should be from 5 to 14 symbols in length.
Click OK.

¾ To add an authorized user of a protected directory:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Password-protected Directories (in the Advanced
Operations group).
3. Click on the name of the directory you need.
4. Click the Add New User icon.
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5. Specify the login name and password that will be used for accessing the
protected area. The password should be from 5 to 14 symbols in length.
6. Click OK.

¾ To change password for an authorized user of a protected directory:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Password-protected Directories (in the Advanced
Operations group).
3. Click on the name of the directory you need. A list of authorized users will
open.
4. Click on the user’s name.
5. Specify the new password and re-type it for confirmation.
6. Click OK.

¾ To revoke a permission to access the protected directory from a user:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Password-protected Directories (in the Advanced
Operations group).
3. Click on the name of the directory you need. A list of authorized users will
open.
4. Select a checkbox corresponding to the user’s name.
5. Click Remove. Confirm the operation and click OK.

¾ To remove password protection and make the resource available to the public:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Password-protected Directories (in the Advanced
Operations group).
3. Select a checkbox corresponding to the name of the directory, from which
you want to remove protection.
4. Click Remove Protection. The protection will be removed and the contents of
the directory will be accessible to the public without restrictions.
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Securing Connections to Websites with SSL
For every e-commerce website hosted on the server, you should purchase and install an
authentic digital SSL certificate.
SSL certificates are used for establishing secure communication channels on the Internet
and for verifying website identity: When users visit your secure online store, they are notified
that your website is really what it claims to be and that all sensitive data, such as credit card
numbers, will be transferred over a secure channel.
You can choose any of the following ways for purchasing and installing SSL certificates:


Use a link in the Panel for purchasing SSL certificates. The link in the Panel, by default,
refers to the MyPlesk.com online store which simplifies purchasing SSL certificates from
Comodo, GeoTrust, Inc, and GoDaddy. This link can be modified by your provider to refer
you to their own site.



Create a certificate signing request (CSR) from the Panel and submit it to the certification
authority of your choice, which will create an SSL certificate for you.

¾ To purchase an SSL certificate using the links in the Panel, and secure a site:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Click the Websites & Domains tab.
3. Click SSL Certificates. A list of SSL certificates that you have in your repository
will be displayed.
4. Click Add SSL Certificate.
5. Specify the following:


Certificate name. This will help you identify this certificate in the repository.



Encryption level. Choose the encryption level of your SSL certificate. We recommend
that you choose a value more than 1024 bit.



Your location and organization name. The values you enter should not exceed the
length of 64 symbols.



The domain name for which you want to purchase an SSL certificate. This should be a
fully qualified domain name. Example: your-domain.com.



The website administrator's e-mail address.

6. Make sure that all the provided information is correct and accurate, as it will
be used to generate your private key.
7. Click Buy SSL Certificate.
Your private key and certificate signing request will be generated. Do not delete them.
MyPlesk.com or another online store configured by the provider will open in a new
browser window or tab.
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8. Register or log in to an existing account and you will be taken step by step
through the certificate purchase procedure.
9. Choose the type of certificate that you wish to purchase.
10. Click Proceed to Buy and order the certificate. In the Approver E-Mail drop-down
box, select the correct approver e-mail.
The approver e-mail is an e-mail address that can confirm that certificate for specific
domain name was requested by an authorized person. This is the e-mail address listed in
the domain owner or domain administrator's contact information in the WHOIS database.

11. Once your certificate request is processed, you will be sent a confirmation email. After you confirm, the SSL certificate will be sent to your e-mail.
12. When you receive your SSL certificate, save it on your computer.
13. Return to the SSL certificates repository (Websites & Domains tab > SSL
Certificates).
14. Upload the SSL certificate: Click Browse in the middle of the screen and
navigate to the location of the saved certificate. Select it, and then click Send
File.
This will upload and install the certificate against the corresponding private key.

15. To install the certificate on a site, return to the Websites & Domains tab, and
click Web Hosting Settings.
16. From the SSL certificate menu, select your SSL certificate and click OK.

¾ To obtain an SSL certificate from any certificate authority of your choice, and
secure a site:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Click the Websites & Domains tab.
3. Click SSL Certificates. A list of SSL certificates that you have in your repository
will be displayed.
4. Click Add SSL Certificate.
5. Specify the certificate properties:


Certificate name. This will help you identify this certificate in the repository.



Encryption level. Choose the encryption level of your SSL certificate. We recommend
that you choose a value more than 1024 bit.



Your location and organization name. The values you enter should not exceed the
length of 64 symbols.



The domain name for which you want to purchase an SSL certificate. This should be a
fully qualified domain name. Example: your-domain.com.



The website administrator's e-mail address.
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6. Make sure that all the provided information is correct and accurate, as it will
be used to generate your private key.
7. Click Request. Your private key and certificate signing request will be
generated and stored in the repository.
8. In the list of certificates, click the name of the certificate you need. A page
showing the certificate properties opens.
9. Locate the CSR section on the page, and copy the text that starts with the line
-----BEGIN CERTIFICATE REQUEST----- and ends with the line -----END CERTIFICATE
REQUEST----- to the clipboard.
10. Visit the website of the certification authority from which you want to
purchase an SSL certificate, and follow the links on their site to start a
certificate ordering procedure. When you are prompted to specify CSR text,
paste the data from the clipboard into the online form and click Continue. The
certification authority will create an SSL certificate in accordance with the
information you supplied.
11. When you receive your SSL certificate, save it on your local machine or
network.
12. Return to the SSL certificates repository (Websites & Domains tab > SSL
Certificates).
13. Upload the SSL certificate: Click Browse in the middle of the page and
navigate to the location of the saved certificate. Select it, and then click Send
File.
This will upload and install the certificate against the corresponding private key.

14. To install the certificate on a site, return to the Websites & Domains tab, and
click Web Hosting Settings.
15. From the SSL certificate menu, select your SSL certificate and click OK.

In this section:
Ordering SSL Certificates Through the Billing Panel........................................... 63
Using SSL Certificate Shared By Another Domain (Windows Hosting) .............. 65
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Ordering SSL Certificates Through the Billing Panel
If your Control Panel is integrated with a billing system, then you might be able to purchase
an SSL certificate for a site from the Account tab.

¾ To purchase an SSL certificate and install in on a site:
1. Go to the Account tab.
2. In the list of subscriptions, click the Add Subscription link.
3. Select the option or plan related to SSL certificates and click Buy Now. Follow
the instructions on the screen to complete the order.
4. Go to the Websites & Domains tab > SSL Certificates, select the domain name you
need, and click Add SSL Certificate.
5. Specify the certificate properties:


Certificate name. This will help you identify this certificate in the repository.



Encryption level. Choose the encryption level of your SSL certificate. We recommend
that you choose a value more than 1024 bit.



Your location and organization name. The values you enter should not exceed the
length of 64 symbols.



The domain name for which you want to purchase an SSL certificate. This should be a
fully qualified domain name. Example: your-domain.com.



The website administrator's e-mail address.

6. Make sure that all the provided information is correct and accurate, as it will
be used to generate your private key.
7. Click Request. Your private key and certificate signing request will be
generated and stored in the repository.
8. In the list of certificates, click the name of the certificate you need. A page
showing the certificate properties opens.
9. Locate the CSR section on the page, and copy the text that starts with the line
-----BEGIN CERTIFICATE REQUEST----- and ends with the line -----END CERTIFICATE
REQUEST----- to the clipboard.
10. Return to the Account tab.
11. In the list of subscriptions, locate the link Request SSL Certificate and click it.
12. In the Certificate signing request field, paste the text from the clipboard that you
previously copied at the step 9.
13. Click Next.
14. Verify that the information in your request is correct and click Next.
15. Select the administrative contact e-mail and click Next.

64

Hosting and Managing Websites

16. Specify technical and billing contact information and click Next.
17. Review the information presented on the screen and click Submit Certificate
Request.
18. After you receive your certificate by e-mail, return to the Websites & Domains
tab > SSL Certificates, and select the domain name for which you ordered the
certificate.
19. Upload the SSL certificate to the Panel: Click Browse in the middle of the
screen and navigate to the location of the saved certificate. Select it, and
then click Send File.
This will upload and install the certificate against the corresponding private key.

20. To install the certificate on a site, return to the Websites & Domains tab, and
click Web Hosting Settings.
21. From the SSL certificate menu, select your SSL certificate and click OK.
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Using SSL Certificate Shared By Another Domain (Windows
Hosting)
If your hosting service provider offers shared SSL for securing access to sites, then you can
switch on SSL encryption without purchasing your own SSL certificate.

¾ To secure connections to a site by using an SSL certificate shared by your
provider:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Shared SSL (in the Advanced Operations group).
3. Select the domain name of the site that you want to secure.
4. Select the Switch on shared SSL checkbox.
5. Specify the virtual directory name in the corresponding input field. The virtual
directory with the supplied name will be created under the domain whose
SSL certificate is shared (called master SSL domain). This directory will be
used for accessing your site through SSL.
For example, let us suppose that you have a domain named mydomain.com, the master
SSL domain is defined as master_ssl_domain.com, and the virtual directory name you
supplied is my_virtual_dir. In this case, to access your site through SSL, you need to
use the following address: https://master_ssl_domain.com/my_virtual_dir.
Note: You cannot use your domain name (for example, mydomain.com) to access your
site via SSL if you are using shared SSL.

6. Select the directory where protected content is located under your website.
The documents within the specified directory will be accessible only through
SSL.
7. To make your domain accessible via SSL only, select the checkbox Make this
website accessible only through secure connections.
8. Click OK.
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Deploying Databases
If your website incorporates custom data processing applications or is designed to generate
web pages dynamically, you will likely need a database for storing and retrieving data. You
can either create a new database for your site or import the data from your previously backed
up MySQL, PostgreSQL, or Microsoft SQL database. Note that when you install an
application from the Applications Catalog, all required databases and database user
accounts are created automatically.

¾ To create a new database on a hosting account:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Click the Websites & Domains tab.
3. Click Databases (in the Advanced Operations group).
4. Click Add New Database.
5. Enter a name for the database.
We recommend that you choose a name that starts with a Latin alphabet symbol and
comprises only alphanumeric and underscore symbols (up to 64 symbols).

6. Select the database type that you are going to use: MySQL, PostgreSQL or
Microsoft SQL Server. Click OK.
7. To set up database administrator’s credentials, click Add New Database User.
8. Type a user name and a password that will be used for accessing the
contents of the database.
9. Click OK.

¾ To import an existing database:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Databases (in the Advanced Operations group) >
Add New Database.
3. Enter a name for the database. We recommend that you choose a name that
starts with a Latin alphabet symbol and comprises only alphanumeric and
underscore symbols (up to 64 symbols).
4. Select the database type that you are going to use: MySQL, PostgreSQL, or
Microsoft SQL Server. Click OK.
5. To set up database administrator’s credentials, click Add New Database User.
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6. Type a user name and a password that will be used for accessing the
contents of the database. Click OK.
7. Click the Webadmin icon in the Tools group. An interface to phpMyAdmin,
phpPgAdmin, or ASPEnterpriseManager database management tool will
open in a separate browser window. The database management tools allow
to operate database user accounts and execute SQL queries through the
web browser.
If you have a MySQL database:

a. Click Query window in the left frame, click the Import files tab,
b. Select the text file that contains the data and click Go.
c. Click the Insert data from a text file link.
If you have a MS SQL database:

a. Click the name of your database in the left frame
b. Click Query (the magnifying glass button)
c. Copy the text of your script into the text area and click Run Query.
To manage your databases and their contents, use your favorite MySQL, PostgreSQL, or
Microsoft SQL Server client or the web-based database management tool accessible from
the Panel (the Websites & Domains tab > Databases > database name > Webadmin).
If you collaborate with other people on managing a website and wish to give them access to
the database, you should create separate user accounts for them.

¾ To create a database user account:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Databases > database name, and click Add New
Database User.
3. Type a user name and a password that will be used for accessing the
contents of the database. Click OK.

¾ To change a password for a database user:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Databases > database name > database user
name.
3. Type a new password and click OK.
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¾ To specify whose user account credentials should be used by default for
managing a database through the Webadmin tool:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Databases > database name.
3. Select a checkbox corresponding to the user account you need.
4. Click Default for DB Webadmin.

¾ To remove a database user account:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Databases > database name.
3. Select a checkbox corresponding to the user account that you want to
remove.
4. Click Remove, then confirm removing and click OK.

¾ To remove a database with its contents:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Databases.
3. Select a checkbox corresponding to the database that you want to remove.
If the required checkbox appears grayed out, this means that this database is used by a
web application and you can remove it only by removing the respective application.

4. Click Remove.
5. Confirm removal and click OK.
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Accessing Data From External Databases (Windows
Hosting)
If your applications need to access external databases for storing data, then you need to
create ODBC connections through the Panel.

¾ To create an ODBC connection to an external database:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > ODBC Data Sources (in the Advanced Operations
group).
3. Click Add New ODBC DSN.
4. Specify the ODBC connection name and description in the corresponding
fields.
5. Select the required driver in the Driver field.
6. Click OK.
7. Choose the appropriate options on the driver configuration screen. Typically,
you should specify the path to the database, user credentials and other
connection options, depending on the selected driver.
8. Click Test Connection to check whether the connection will function properly
with provided settings. Click Finish to complete the creation.

¾ To change settings of an ODBC connection:
1. Go to the Websites & Domains tab > ODBC Data Sources (in the Advanced Operations
group).
2. Click the required connection name in the list.
3. Change the settings as needed.
4. Click Test Connection to check whether the connection will function properly
with new settings. Click Finish to save changes.

¾ To remove an ODBC connection:
1. Go to the Websites & Domains tab > ODBC Data Sources (in the Advanced Operations
group).
2. Select the checkbox corresponding to a connection you want to remove.
3. Click Remove, confirm the removal and click OK.

70

Hosting and Managing Websites

Protecting Sites from Bandwidth Stealing (Windows
Hosting)
Hotlinking (also called file leeching, remote linking, direct linking, bandwidth stealing or
bandwidth banditism) is a term used for describing a situation when a web page of one
domain owner is directly linking to images (or other multimedia files) on the web pages of
another domain owner, usually using an <IMG> tag. If your domains are hotlinked, you may
face the problem of excessive bandwidth usage.

¾ To protect a website from hotlinking:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Hotlink Protection (in the Advanced Operations
group).
3. Click Switch On to enable the protection from hotlinking.
4. Specify the extensions of files that you want to protect from hotlinking (for
example, jpg, bmp, and so on) in the Protected files extensions field. When
listing several file extensions, separate them with white spaces.
5. If you want to allow direct linking to your files from certain sites, type the
website addresses into the Addresses of friendly websites field, and click Add.
6. Click OK.
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Limiting Bandwidth Use and Number of Connections to
Websites
To avoid excessive usage of bandwidth, and protect your site from Denial Of Service attacks,
you can limit bandwidth usage for a site and number of simultaneous connections.

¾ To limit bandwidth usage and number of connections to a site:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Bandwidth Limiting (in the Advanced Operations
group).
3. Select the Switch on bandwidth limiting checkbox.
4. In the Maximum bandwidth usage (KB/S) box, specify the maximum speed,
measured in kilobytes per second, that a website can share among all its
connections.
5. Select the Switch on connections limiting checkbox.
6. In the Connections limited to box, specify the maximum number of simultaneous
connections to the site.
7. Click OK.
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Setting Up and Managing Dedicated IIS Application Pool for
Your Websites
IIS Application Pool contains all web applications installed on your sites. If your service
provider allocated a dedicated IIS application pool for your sites, then you can have a level of
isolation between web applications used by your sites and web applications used by other
hosting users who host their websites on the same server. Because each application pool
runs independently, errors in one application pool will not affect the applications running in
other application pools.
Once you switch on the application pool, all web applications on your websites will be using
it.

¾ To switch on dedicated IIS application pool for your websites:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Dedicated IIS Application Pool for Your Websites
(in the Advanced Operations group).
3. Click Switch On.
4. To limit the amount of CPU resources that this application pool can use,
select the Switch on CPU monitoring checkbox and type a number in percents
into the Maximum CPU use (%) box.
5. Click OK.

¾ To stop all applications running in the application pool:
1. Go to the Websites & Domains tab > Dedicated IIS Application Pool for Your Websites
(in the Advanced Operations group).
2. Click Stop.

¾ To start all applications in the application pool:
1. Go to the Websites & Domains tab > Dedicated IIS Application Pool for Your Websites
(in the Advanced Operations group).
2. Click Start.
If you run applications that are known to have memory leaks or become unstable after
working for a long time, then you might need to restart them from time to time.
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¾ To restart all applications running in the application pool:
1. Go to the Websites & Domains tab > Dedicated IIS Application Pool for Your Websites
(in the Advanced Operations group).
2. Click Recycle.

¾ To switch off the dedicated IIS application pool for your websites:
1. Go to the Websites & Domains tab > Dedicated IIS Application Pool for Your Websites
(in the Advanced Operations group).
2. Click Switch Off.

Configuring ASP.NET Settings for Websites
¾ To configure ASP.NET Settings for a site:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > ASP.NET Settings (in the Advanced Operations
group).
3. Set up the strings that determine database connection data for ASP.NET
applications that use databases. This option is available only for ASP.NET
2.0.x.
When you open the ASP.NET configuration screen for the first time, sample
connection parameters with common constructions are displayed. You can delete
them and specify your own strings.


To add a string, enter the required data into the Name and Connection Parameters input
fields and click
next to them.



To remove a string, click

next to it.

4. Set up custom error messages that will be returned by ASP.NET applications
in the Custom Error Settings field:




To set the custom error messages mode, select an appropriate option from the Custom
error mode menu:


On - custom error messages are enabled.



Off - custom error messages are disabled and detailed errors are to be shown.



RemoteOnly - custom error messages are displayed only to remote clients, and
ASP.NET errors are shown to the local host users.

To add a new custom error message (which will be applied unless the Off mode was
selected), enter the values in the Status Code and Redirect URL fields, and click .
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Status Code defines the HTTP status code resulting in redirection to the error page.



Redirect URL defines the web address of the error page presenting information
about the error to the client.

Due to possible conflicts, you cannot add a new custom error message with an error
code that already exists, but you can redefine the URL for the existing code.


To remove a custom error message from the list, click

next to it.

5. Configure compilation settings in the Compilation and Debugging field:


To determine the programming language to be used as default in dynamic compilation
files, choose an entry from Default web page language list.



To enable compiling retail binaries, leave the Switch on debugging checkbox empty.



To enable compiling debug binaries, select the Switch on debugging checkbox. In this
case, the source code fragments containing error will be shown in a diagnostic page
message.

Note. When running applications in debug mode, a memory and/or performance
overhead occurs. It is recommended to use debugging when testing an application and to
disable it before deploying the application into production scenario.

6. Configure encoding settings for ASP.NET applications in the Globalization
Settings section:


To set an adopted encoding of all incoming requests, enter an encoding value into the
Request encoding field (default is utf-8).



To set an adopted encoding of all responses, enter an encoding value into the
Response encoding field (default is utf-8).



To set an encoding which must be used by default for parsing of .aspx, .asmx, and
.asax files, enter an encoding value into the File encoding field (default is Windows1252).



To set a culture which must be used by default for processing incoming web requests,
select an appropriate item from the Culture list.



To set a culture which must be used by default when processing searches for a
locale-dependent resource, select an appropriate item from the UI Culture list.

7. Set a code access security trust level for ASP.NET applications in the Code
Access Security field.
CAS trust level is a security zone to which applications execution is assigned, defining
what server resources the applications will have access to.
Important: When an assembly is assigned a trust level that is too low, it does not
function correctly. For more information on the permissions levels see
http://msdn.microsoft.com/library/enus/dnnetsec/html/THCMCh09.asp?frame=true#c09618429_010.

8. Enable the usage of the auxiliary scripts in the Script Library Settings field.
Specifying the script library settings is necessary if the validation web
controls are used on your web site. This option is available only for ASP.NET
1.1.x.

Hosting and Managing Websites

75



If you need to use auxiliary scripts (specifically, scripts implementing objects for
validating input data), provide the settings for .NET framework script library. To do so,
enter the path beginning with the domain root directory preceded by the forward slash
into the Path to Microsoft script library field, or click the folder icon next to the Path to
Microsoft script library field and browse for the required location.



To initiate the auto-installation of files containing the scripts to the specified location,
select the Install checkbox. If the files already exist there, they will be rewritten.

9. Set client session parameters in the Session Settings field:


To set up the default authentication mode for applications, select an appropriate item
from the Authentication mode list. Windows authentication mode should be selected if
any form of IIS authentication is used.



To set up time that a session can remain idle, type the number of minutes into the
Session timeout box.

10. Click OK to apply all changes.

Hosting Personal Web Pages Under Your Domains
You can host on your web server personal web pages for users who do not need their own
domain names. These pages usually have web addresses like http://yourdomain.com/~username.

¾ To accommodate a personal web page under your domain and set up an FTP
account for publishing:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Web Users (in the Advanced Operations group).
3. Click Settings.
4. If you want to allow execution of scripts embedded in personal web pages,
select the Allow web users to use scripts checkbox.
5. Click OK.
The settings you have defined at the step 4 are common for all personal web pages you
might host on your account. Therefore, you will not need to perform the steps from 3 to 5
next time you set up a new web user account.

6. Click Add New Web User.
7. Specify a username and a password that will be used for accessing the
webspace through FTP and publishing the web pages.
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You can use only lower-case alphanumeric, hyphen and underscore symbols in the
username. The username should begin with an alphabet character. It cannot contain
white spaces. The password cannot contain quotation marks, white space, username,
and should be between 5 and 14 characters in length.

8. If you want to limit the amount of disk space that can be occupied by the web
page content, type the desired value in megabytes into the Hard disk quota
box.
When the specified limit is exceeded, the web page owner will not be able to add files to
his or her webspace.

9. Specify the programming languages that should be supported for the web
page.
For example, if the web page is written in PHP, select the PHP support checkbox.

10. If you use a Windows-based hosting account and this personal web page's
applications need to use a file-based database (like Jet) located in the root
of httpdocs directory, select the Additional write/modify permissions option. Note
that selecting this option might seriously compromise the website security.
11. Click OK.
Now you can tell your user the FTP account credentials, so that he or she can publish their
web page.

¾ To change FTP password for a web page owner:
1. Go to the Websites & Domains tab > Web Users.
2. Click the user name you need.
3. Type the new password into the New password and Confirm password boxes.
4. Click OK.

¾ To allocate more disk space to the web page owner:
1. Go to the Websites & Domains tab > Web Users.
2. Click the user name you need.
3. Type the amount of disk space in megabytes into the Hard disk quota box.
4. Click OK.

¾ To remove a web page owner’s account together with their web page:
1. Go to the Websites & Domains tab > Web Users.
2. Select a checkbox corresponding to the user account you want to remove
and click Remove.
3. Confirm removal and click OK.
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Setting Up Additional Domain Names for a Site (Domain
Aliases)
If you have registered with a domain name registrar several domain names that you would
like to point to the same website that you host on this server, you should set up domain
aliases.

¾ To set up a domain alias:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Domain Aliases (in the Advanced Operations
group).
3. Click Add Domain Alias.
4. Type the desired domain alias name, for example alias.com.
Domain aliases can comprise letters, digits and hyphens. Each part of the domain alias
between dots should not be longer than 63 symbols.

5. Select the Synchronize DNS zone with the primary domain checkbox if you want the
domain alias to use the same DNS zone resource records as in primary
domain. With this setting, any subsequent changes in resource records of
the primary domain's zone will be applied to the DNS zone of this domain
alias.
6. Select the Mail service checkbox, if you want e-mail directed at the e-mail
addresses under the domain alias to be redirected to the e-mail addresses
under your original domain name.
Example: You have an e-mail address mail@yourdomain.com. You have set up an alias
for your domain name, for example, alias.com. If you want to receive mail to your mailbox
mail@yourdomain.com when it is sent to mail@alias.com, select the Mail service
checkbox.

7. Select the Web service checkbox. Otherwise, the web server will not serve the
web content to users coming to your site by typing the domain alias in their
browsers.
8. If you use hosting services based on a Linux platform, and you have Java
applications installed on your site that you want to make accessible through
the domain alias, select the Java web applications checkbox.
9. Click OK.
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¾ To change the properties of an alias:
1. Go to the Websites & Domains tab > Domain Aliases (in the Advanced Operations
group).
2. Click the alias name you need.
3. Click Preferences in the Tools group.
4. Modify the domain alias properties as required and click OK.

¾ To modify resource records in the DNS zone of a domain alias:
1. Go to the Websites & Domains tab > Domain Aliases (in the Advanced Operations
group).
2. Click the alias name you need.
3. Click DNS Settings.
4. Add, edit or remove the resource records as required:


To add a resource record to the zone, click Add New Record. Specify the required
values and click OK to write the values to the zone.



To modify a resource record, under the Host column, click a hyperlink corresponding
to the record you need.



To remove a record, select a checkbox corresponding to the record you wish to
remove and click Remove.

¾ To remove an alias from a domain:
1. Go to the Websites & Domains tab > Domain Aliases (in the Advanced Operations
group).
2. Select a checkbox corresponding to the domain alias that you want to
remove.
3. Click Remove.
4. Confirm removal and click OK.
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Using Virtual Directories (Windows Hosting)
A virtual directory is a link to an existing physical directory that is present on the server's hard
disk. Virtual directories can have a number of specific settings like custom ASP.NET
configuration, access permissions, and protection with a password.
Because any virtual directory can have its own settings, including customized ASP.NET
configuration, virtual directories are very useful in setting up your web applications, especially
those written in ASP.NET. For example, if you have three web applications that use
ASP.NET version 1.1, and you need to install one web application that uses ASP.NET
version 2.0, you can create a virtual directory for the ASP.NET 2.0 application, configure
ASP.NET settings for this directory so as to enable support for version 2.0, and then
successfully install the required application.
Virtual directories can also be used as aliases. For example, you have a web application
installed on your domain "example.com" in the physical directory
"/my_data/web_apps/forum". To access this web application, users need to type
"example.com/my_data/web_apps/forum", which is hard to remember and too long to
type. You can create virtual directory called forum in the root of your virtual host, and link
this virtual directory to "/my_data/web_apps/forum", so the users who want to access
the web application will need to type "example.com/forum", which is much shorter and
easier to remember.

In this section:
Creating Virtual Directories ................................................................................. 80
Configuring ASP.NET Settings for Virtual Directories ......................................... 81
Configuring PHP Settings for Virtual Directories ................................................. 83
Setting Access Permissions for Virtual Directories ............................................. 84
Changing Virtual Directory Settings .................................................................... 85
Adding and Removing MIME Types .................................................................... 87
Restricting Access to the Virtual Directory with Password Protection ................. 88
Removing Virtual Directories ............................................................................... 89
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Creating Virtual Directories
¾ To create a virtual directory:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations
group). You are in your web site root now.
3. Navigate to the directory in which you want to create a new virtual directory.
4. Click Create Virtual Directory.
Note: To create a physical directory instead of virtual directory, click Create Directory,
specify the name of the directory and click OK.

5. Specify the required parameters:


Name - specify the virtual directory name.



Path - specify the virtual directory path:


Select the Create physical directory with the same name as virtual directory checkbox to
automatically create a physical directory with the same name as the virtual
directory you are creating.



Clear the Create physical directory with the same name as virtual directory checkbox and
specify the path in the field to select a physical directory that already exists.



Script source access - select this checkbox to allow users to access source code if
either Read or Write permissions are set. Source code includes scripts in ASP
applications.



Read permission - select this checkbox to allow users to read files or directories and
their associated properties.



Write permission - select this checkbox to allow users to upload files and their
associated properties to the virtual directory or to change content in a write-enabled
file. Write access is allowed only if browser supports the PUT feature of the HTTP 1.1
protocol.



Directory browsing - select this checkbox to allow users to see a hypertext listing of the
files and subdirectories in the virtual directory.



Log visits - select this checkbox if you want to store the information about visits of the
virtual directory.



Create application - select this checkbox to make the directory an IIS application. The
directory becomes logically independent from the rest of the website.



Execute permissions - select the appropriate program execution level allowed for the
virtual directory.


None - allow access only to static files such as HTML or image files.



Scripts only - allow running scripts only, not executables.
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Scripts and Executables - remove all restrictions so that all file types can be
executed.

ASP Settings - set specific settings for ASP-based web applications.


If you are using ASP-based applications that cannot operate correctly under data
transfer restrictions currently set by IIS, clear the Defined by parent directory
checkbox corresponding to the field you want to change and type in the required
number.



If you want to enable debugging of ASP applications on the server side, clear the
corresponding Defined by parent directory checkbox and select the Enable ASP serverside script debugging checkbox.



If you want to enable debugging of ASP applications on the client side, clear the
corresponding Defined by parent directory checkbox and select the Enable ASP clientside script debugging checkbox.

Note that if you are trying to change ASP Settings for the root virtual directory, the
default checkbox names will be Defined by IIS instead of Defined by parent directory.

6. Click OK.

Configuring ASP.NET Settings for Virtual Directories
¾ To configure ASP.NET settings for a virtual directory:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations
group).
3. Browse to the required directory and click a link with its name.
4. Click ASP.NET Settings.
5. Set up the strings that determine database connection data for ASP.NET
applications that use databases. This option is available only for ASP.NET
2.0.x.
When you open the ASP.NET configuration page for the first time, sample connection
parameters with common constructions are displayed. You can delete them and
specify your own strings.


To add a string, enter the required data into the Name and Connection Parameters input
next to them.
fields and click



To remove a string, click

next to it.

6. Set up custom error messages that will be returned by ASP.NET
applications:


To set the custom error messages mode, select an appropriate option from the Custom
error mode menu:
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On - custom error messages are enabled.



Off - custom error messages are disabled and detailed errors are to be shown.



RemoteOnly - custom error messages are displayed only to remote clients, and
ASP.NET errors are shown to the local host.

To add a new custom error message (which will be applied unless the Off mode was
selected), enter the values in the Status Code and Redirect URL fields, and click .


Status Code defines the HTTP status code resulting in redirection to the error page.



Redirect URL defines the web address of the error page presenting information
about the error to the client.

Due to possible conflicts, you cannot add a new custom error message with an error
code that already exists, but you can redefine the URL for the existing code.


To remove a custom error message from the list, click

next to it.

7. Configure compilation settings in the Compilation and Debugging field:


To determine the programming language to be used as default in dynamic compilation
files, choose an entry from the Default web page language menu.



To enable compiling of retail binaries, leave the Switch on debugging checkbox empty.



To enable compiling of debug binaries, select the Switch on debugging checkbox. In this
case, the source code fragments containing error will be shown in a diagnostic
message.

Note: When running applications in debug mode, a memory and performance overhead
occurs. We recommended that you use debugging when testing an application, and
disable it before deploying the application into production scenario.

8. Configure encoding settings for ASP.NET applications in the Globalization
Settings section:


To set an adopted encoding of all incoming requests, enter an encoding value into the
Request encoding field (default is utf-8).



To set an adopted encoding of all responses, enter an encoding value into the
Response encoding field (default is utf-8).



To set an encoding which must be used by default for parsing of .aspx, .asmx, and
.asax files, enter an encoding value into the File encoding field (default is Windows1252).



To set a culture which must be used by default for processing incoming web requests,
select an appropriate item from the Culture list.



To set a culture which must be used by default when processing searches for a
locale-dependent resource, select an appropriate item from the UI Culture list.

9. Set a code access security trust level for ASP.NET applications in the Code
Access Security field.
CAS trust level is a security zone to which applications execution is assigned, defining
what server resources the applications will have access to.
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Important: When an assembly is assigned a trust level that is too low, it does not
function correctly. For more information on the permission levels, see
http://msdn.microsoft.com/library/enus/dnnetsec/html/THCMCh09.asp?frame=true#c09618429_010.

10. If you are using ASP.NET 1.1.x, then you can enable the usage of the
auxiliary scripts in the Script Library Settings field. Specifying the script library
settings is necessary if the validation web controls are used on your web
site.


If you need to use auxiliary scripts (specifically, scripts implementing objects for
validating input data), provide the settings for .NET framework script library. To do so,
enter the path beginning with the domain root directory preceded by the forward slash
into the Path to Microsoft script library field, or click the folder icon next to the Path to
Microsoft script library field and browse for the required location.



To initiate installation of files containing the scripts to the specified location, select the
Install checkbox. If the files already exist there, they will be rewritten.

11. Set client session parameters in the Session Settings field:


To set up the default authentication mode for applications, select an appropriate item
from the Authentication mode list. Windows authentication mode should be selected if
any form of IIS authentication is used.



To set up the allowed session idle time, enter appropriate number minutes into the
Session timeout field.

12. Click OK to apply all changes.

Configuring PHP Settings for Virtual Directories
To be able to use web applications that require PHP4 or PHP5, you can select the required
PHP version for individual virtual directories.

¾ To select PHP version for a virtual directory:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations
group).
3. Browse to the required directory and click a link with its name.
4. In the Tools group, click PHP Settings.
5. Select the required version of PHP and click OK.

84

Hosting and Managing Websites

Setting Access Permissions for Virtual Directories
¾ To set access permissions for a virtual directory:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations
group).
3. To set access permissions for the current virtual directory, in the Tools group,
click Directory Access Permissions. If you want to set permissions for a
subdirectory located within the current directory, click the corresponding icon
.
4. Do the following:


To make the file/folder inherit permissions from a parent folder (if it does not), select
the checkbox Allow inheritable permissions from the parent to propagate to this object and all
child objects. Include these with entries explicitly defined here.



To make the files and folders, which are contained in this folder, inherit the folder
permissions you define, select the checkbox Replace permission entries on all child objects
with entries shown here that apply to child objects.



To change or remove permissions from a group or a user, click the required name in
the Group or user names list. If the group or user is not listed in the Group or user names
list, select the required user or group name from the menu located above the list and
click : the user/group appears in the list. Select it.
To allow or deny permissions to a selected group/user, select the Allow or Deny
checkboxes corresponding to permissions listed under Permissions for <user/group
name>. If the checkboxes in Allow or Deny columns are shown in grey, it means that the
corresponding permissions are inherited from a parent folder.



To deny the permissions, which are inherited from a parent object as allowed, select
the required checkboxes under Deny. This will override inherited permissions for this
file/folder.



To allow the permissions, which are inherited from a parent object as denied, clear the
Allow inheritable permissions from the parent to propagate to this object and all child objects.
Include these with entries explicitly defined here checkbox: this removes the inherited
permissions. Then select the required checkboxes under Allow and Deny.



To remove access permissions from a group or user, select the required name in the
next to it.
Group or user names list and click the icon

5. If you need advanced fine-tuning of permissions, click the Advanced button,
and do the following:


To create a permission entry for a group or user, select the required name from the
Group or user names list and click .



To set or change file/folder permissions for a group or user, select the required name
from the Group or user names list, select the required Allow and Deny checkboxes
corresponding to permissions listed under Permissions for <user/group name>.
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To remove a permission entry for a group or user, select the required name from the
Group or user names list and click .



To make child objects of a folder inherit its permissions defined under Permissions for
<user/group name>, select the Replace permission entries on all child objects with entries
shown here that apply to child objects checkbox, and select checkboxes in the Apply to list
which correspond to the objects that must inherit the permissions.

6. Click OK.

Changing Virtual Directory Settings
¾ To change settings of a virtual directory:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations
group).
3. Browse to the directory whose preferences you want to change, and click the
corresponding icon , or click Directory Properties when inside the required
directory.
4. Change the settings as required:


Name - specify virtual directory name.



Path - specify the path to the physical directory to which the virtual directory is linked.



Script source access - select this checkbox to allow users to access source code if
either Read or Write permissions are set. Source code includes scripts in ASP
applications.



Read permission - select this checkbox to allow users to read files or directories and
their associated properties.



Write permission - select this checkbox to allow users to upload files and their
associated properties to the virtual directory or to change content in a write-enabled
file. Write access is allowed only if browser supports the PUT feature of the HTTP 1.1
protocol.



Directory browsing - select this checkbox to allow users to see a hypertext listing of the
files and subdirectories in the virtual directory.



Log visits - select this checkbox if you want to store the information about visits to the
virtual directory.



Create application - select this checkbox to make the web directory an IIS application.
The directory becomes logically independent from the rest of the website.



Execute permissions - select the appropriate program execution level allowed for the
virtual directory.


None - allow access only to static files such as HTML or image files.
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Scripts only - allow running scripts only, not executables.



Scripts and Executables - remove all restrictions so that all file types can be
executed.



Allow to use parent paths - select this checkbox to allow using double period in the path
name when referring to a folder above the current directory. This enables users to
move up the folder tree without knowing the folder name or the whereabouts in the
hierarchy. If the option is selected, parent path directories should not have the Execute
permission checkbox selected in their properties, so that applications do not have the
ability of unauthorized running of programs in the parent paths.



Allow application execution in MTA (multi-threaded apartment) mode - select this checkbox to
allow the application execution in multi-threaded apartment (MTA) mode. Otherwise,
the application will run in a single-threaded apartment (STA) mode. Using STA, each
application pool is executed in a dedicated process. With MTA, several concurrent
application pools are executed in one thread which can increase performance in some
cases.



Use default documents - select this checkbox to allow the use of default documents for
the current directory. The default document is sent when users access the directory
on the web without a specific file name (for example, using http://www.example.com
as opposed to http://www.example.com/index.html). If this checkbox is cleared and
the Directory browsing checkbox is selected, the web server returns a folder listing. If
this checkbox is cleared and the Directory browsing checkbox is cleared as well, the
web server returns an "Access Forbidden" error message.



Default documents search order - specifies the order in which IIS searches for the default
document, sending user the first available file it finds. If no match is found, IIS
behaves as in the cases when the default content page is disabled.



Allow anonymous access - select this checkbox if you want to make the directory public
so that the Internet users could access it without authentication.



Require SSL - select this checkbox to enable access to the folder only via SSLencrypted connections.



ASP Settings - set specific settings for ASP-based web applications.


If you are using ASP-based applications that cannot operate correctly under data
transfer restrictions set by IIS, clear the Defined by parent directory checkbox
corresponding to the field you want to change and type in the required number.



If you want to enable debugging of ASP applications on the server side, clear the
corresponding Defined by parent directory checkbox and select the Enable ASP serverside script debugging checkbox.



If you want to enable debugging of ASP applications on the client side, clear the
corresponding Defined by parent directory checkbox and select the Enable ASP clientside script debugging checkbox.
Note that if you are trying to change ASP Settings for the root directory, the default
checkbox names will be Defined by IIS instead of Defined by parent directory.

5. Click OK to save changes.
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Adding and Removing MIME Types
Multipurpose Internet Mail Exchange (MIME) types instruct a web browser or mail application
how to handle files received from a server. For example, when a web browser requests an
item on a server, it also requests the MIME type of the object. Some MIME types, like
graphics, can be displayed inside the browser. Others, such as word processing documents,
require an external application to be displayed.
When a web server delivers a web page to a client web browser, it also sends the MIME type
of the data it is sending. If there is an attached or embedded file in a specific format, IIS also
tells the client application the MIME type of the embedded or attached file. The client
application then knows how to process or display the data being received from IIS.
IIS can only operate files of registered MIME types. These types could be defined both on
the global IIS level and on the website or virtual directory level. Globally-defined MIME types
are inherited by all websites and virtual directories while ones defined on the website main or
virtual directory level are used only for the area where they are defined. Otherwise, if the web
server receives request for a file with unregistered MIME type, it returns the 404.3 (Not
Found) error.

¾ To add a new MIME type for a virtual directory:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations
group).
3. Navigate to the required virtual directory and click the corresponding link
with its name.
4. Click the MIME Types tab.
5. Click Add MIME Type.
6. Specify the following:


Type the file name extension in the Extension field. File name extension should begin
with a dot (.), or a wildcard (*) to serve all files regardless of file name extension.



Specify the file content type in the Content field.



You can either select the appropriate value from the list or define a new content type.
To do this, select Custom and enter the content type in the input box provided.

7. Click OK to finish the creation.

¾ To edit a MIME type for a virtual directory:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
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2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations
group).
3. Navigate to the required virtual directory and click the corresponding link
with its name.
4. Select the MIME Types tab.
5. Select the required MIME type in the list.


Type the file name extension in the Extension field. File name extension should begin
with a dot (.), or a wildcard (*) to serve all files regardless of file name extension.



Specify the file content type in the Content field.



You can either select the appropriate value from the list or define a new content type.
To do this, select Custom and enter the content type in the input box provided.

6. Click OK to save changes.

¾ To remove a MIME type for a virtual directory:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations
group).
3. Navigate to the required virtual directory and click the corresponding link
with its name.
4. Select the MIME Types tab.
5. Select the checkbox corresponding to the MIME type you want to remove.
6. Click Remove.
7. Confirm removal and click OK.

Restricting Access to the Virtual Directory with Password Protection
¾ To restrict access to files and directories located within a virtual directory:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Virtual Directories.
3. Navigate to the directory you want to protect and click the Protection tab.
4. Click Protect.
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5. To specify users who will be able to access the directory, click Add User,
specify username and password, and click OK.
6. If you want to specify a title for the protected area that will be shown to users
when they attempt to access the directory, click Settings, specify a title, and
click OK.

¾ To revoke a permission to access a directory from a user:
1. Go to the Websites & Domains tab > Virtual Directories > the Protection tab.
2. Select the checkbox corresponding to the user's name and click Remove.

¾ To remove protection from a directory and allow the general public to see the
directory contents without restrictions:
1. Go to the Websites & Domains tab > Virtual Directories > the Protection tab.
2. Click Remove Protection.
3. Click OK to confirm removal.

Removing Virtual Directories
¾ To remove a virtual directory:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Virtual Directories (in the Advanced Operations
group).
3. Select the checkbox corresponding to the directory you want to remove.
4. Click Remove.
5. Confirm the removal and click OK.

90

Hosting and Managing Websites

Setting Up Custom Error Documents
When visitors coming to a site request pages that the web server cannot find, the web server
generates and displays a standard HTML page with an error message. You may want to
create your own error pages and use them for your sites or individual virtual directories. The
following error messages are the ones customized most often:


400 Bad File Request. Usually means the syntax used in the URL is incorrect (for
example, uppercase letter should be lowercase letter; wrong punctuation marks).



401 Unauthorized. Server is looking for some encryption key from the client and is not
getting it. Also, wrong password may have been entered.



403 Forbidden/Access denied. Similar to 401; a special permission is needed to access
the site – a password or username, if it is a registration issue.



404 Not Found. Server cannot find the requested file. File has either been moved or
deleted, or the wrong URL or document name was entered. This is the most common
error.



500 Internal Server Error. Could not retrieve the HTML document because of server
configuration problems.

In this section:
Setting Up Custom Error Documents on Windows-based Hosting Accounts ..... 91
Setting Up Custom Error Documents on Linux-based Hosting Accounts ........... 92
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Setting Up Custom Error Documents on Windows-based Hosting
Accounts
¾ To configure the web server to show custom error pages for a site or a
directory within a site:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Switch on support for custom error documents.
a. Go to the Websites & Domains tab and in the list of domains, click the
domain name you need.
b. Select the Custom error documents checkbox.
c. Click OK.
3. Go to the Websites & Domains tab > Virtual Directories to see the list of error
documents for the root web directory. Error documents located here are
used for all web pages of the selected site. If you want to customize error
pages for a specific virtual directory, navigate to that directory.
4. Click Error Documents tab and click the required error document in the list.


To use the default document provided by IIS for this error page, select Default in the
Type menu.



To use a custom HTML document already located in the error_docs directory in the
virtual host directory of the domain, select File in the Type menu and specify the file
name in the Location field.



To use a custom HTML document located in a directory other than error_docs on
a domain, select URL in the Type menu and enter the path to your document in the
Location field. The path should be relative to the virtual host root (that is,
<vhosts>\<domain>\httpdocs).
For example, you have created a file forbidden_403_1.html and saved it in the
my_errors directory located in the httpdocs. To use this file as an error document,
you need to type the following path into the Location field:
/my_errors/forbidden_403_1.html.

Note: You can use a connection over FTP or File Manager in the Panel to upload your
custom error document to the server. By default, all error documents are stored in the
/vhosts/your-domain.com/error_docs/ directory (located in C:\InetPub by
default).

5. Once the web server is restarted, it will start using your error documents.
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Setting Up Custom Error Documents on Linux-based Hosting
Accounts
¾ To configure the web server to show custom error pages for a site:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Switch on support for custom error documents.
a. Go to the Websites & Domains tab and in the list of domains, click the
domain name you need.
b. Select the Custom error documents checkbox.
c. Click OK.
3. Connect to your FTP account, and go to the error_docs directory.
4. Edit or replace the respective files. Be sure to preserve the correct file
names:


400 Bad File Request - bad_request.html



401 Unauthorized - unauthorized.html



403 Forbidden/Access denied - forbidden.html



404 Not Found - not_found.html



405 Method Not Allowed - method_not_allowed.html



406 Not Acceptable - not_acceptable.html



407 Proxy Authentication Required - proxy_authentication_required.html



412 Precondition Failed - precondition_failed.html



414 Request-URI Too Long - request-uri_too_long.html



415 Unsupported Media Type - unsupported_media_type.html



500 Internal Server Error - internal_server_error.html



501 Not Implemented - not_implemented.html



502 Bad Gateway - bad_gateway.html

The web server will start using your error documents in a few hours, after it is restarted.
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Using Google Services for Websites
Using links in the Panel, you can generate code for inserting a custom Google search engine
into your site, submit your website to Google through Webmaster Tools area, enroll in the
AdSense program, embed YouTube videos, Google Translate service, or other Google
products into your site.
Google Custom Search is a search engine provided by Google. It adds search functions to
your site and allows you to apply your website's look and feel to the search results page. It
can be used for free on websites of individuals and non-profit organizations. Websites related
to for-profit businesses can either use a Custom Search Engine that will show
advertisements from Google, or purchase a subscription to Google Site Search service,
which starts from $100 per year. To learn more about Google Site Search and current prices,
visit http://www.google.com/sitesearch.
Google Webmaster Tools allow webmasters to submit a website to Google and view search
statistics. To learn more about Webmaster Tools, visit
http://www.google.com/support/webmasters/?hl=en.
Google AdSense allows webmasters to earn money for displaying targeted Google ads on
their websites. To learn more about AdSense, visit
https://www.google.com/adsense/login/en/.
Google Web Elements allows webmasters to easily add their favorite Google products to
websites. Embed content, such as news, maps, YouTube videos, and social conversations
from Google Friend Connect to Web pages with simple cut-n-paste. To learn more about
Google Web Elements, visit http://www.google.com/webelements/.
Before you start using Google services, you need to confirm acceptance of Google Terms of
Services, and then confirm ownership for your sites.

¾ To confirm acceptance of Google terms of service and then confirm ownership
of your sites:
1. Go to either the Home tab or the Websites & Domains tab, and click the Google
Services for Websites link.
2. Click the appropriate links in the Panel to open and read the Terms of
Service documents.
3. To confirm that you accept the Terms of Service, select the checkbox and
click Confirm.
Now you can do the following:


Submit your site to Google and improve site visibility in search results by clicking Google
Webmaster Tools.



Add search functions to a site by clicking Add New Custom Search Engine.



Enroll in the AdSense program by clicking Google AdSense.



Embed Google products into your site by clicking Google Web Elements.
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¾ To submit a site to Google:
1. Go to either the Home tab or the Websites & Domains tab, and click the Google
Services for Websites link.
2. Click Google Webmaster Tools.
The Google Webmaster Tools area opens in a new browser window or tab.

3. Create a Sitemap and submit it to Google by following instructions at
http://www.google.com/support/webmasters/bin/answer.py?hl=en&answer=1
56184.

¾ To add a custom search engine to a site:
1. Go to either the Home tab or the Websites & Domains tab, and click the Google
Services for Websites link.
2. Click Custom Site Search.
3. Click Add New Custom Search Engine.
4. Type a search engine name and select the website you need.
5. Select the checkbox to confirm your acceptance of Terms of Service, and
click OK.
The record corresponding to the new search engine is added to the Panel.

6. Click the corresponding Get Code link, copy the generated code to the
clipboard and paste it into the source code of your website pages.
The other links in the list of Custom Search Engines will help you perform the following
operations:


Make Money. Connect your Custom Search Engine to a Google AdSense account. You
make money when users click on an ad they see in your search results. If you have more
than one Custom Search engine, all of your search engines will automatically be
associated with the same AdSense account.



Manage. Manage your Custom Search Engines.



Look and Feel. Adjust the appearance of search box and search results page.



Upgrade. Upgrade a Custom Search Engine to ads-free Google Site Search.



Statistics. Review site search reports.



Delete. Delete a Custom Search Engine.

¾ To participate in the Google AdSense program:
1. Go to either the Home tab or the Websites & Domains tab, and click the Google
Services for Websites link.
2. Click Google AdSense.
3. Click Google AdSense account.
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4. Fill in all the required fields to create a new AdSense account, or select an
existing account, and click OK.
A confirmation e-mail with further instructions will be sent to your e-mail address.

Scheduling Tasks
If you need to run scripts on your hosting account at specific time, use the task scheduler in
the Panel to make the system automatically run the scripts for you.

In this section:
Scheduling Tasks (Linux Hosting) ....................................................................... 95
Scheduling Tasks (Windows Hosting) ................................................................. 97

Scheduling Tasks (Linux Hosting)
If you need to run scripts on your hosting account at specific time, use the task scheduler in
the Panel to make the system automatically run the scripts for you.
During installation of the Panel, the following tasks are automatically created:


autoreport.php – delivers daily, weekly and monthly reports on domains (three
separate tasks)



backupmng – initiates scheduled backing up of domains once every 30 minutes



statistics – generates statistics on resource usage by domains



mysqldump.sh - creates a backup copy of three MySQL databases: psadump, MySQL,
and Horde databases

As all these tasks are related to statistics, databases, and reports, it is strongly
recommended that you neither change nor remove them.

¾ To schedule a task:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Scheduled Tasks (in the Advanced Operations
group).
3. Click Schedule New Task.
4. Leave the Switched on checkbox selected.
5. Specify when to run your command:


Minute - enter the value from 0 to 59



Hour - enter the value from 0 to 23



Day of the month - enter the value from 1 to 31
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Month - enter the value from 1 to 12, or select the month from a drop-down box



Day of the week - enter the value from 0 to 6 (0 for Sunday), or select the day of the
week from a menu.

You can schedule the time using the UNIX crontab entry format. In this format, you can:


Enter several values separated by commas. Two numbers separated by a hyphen
mean an inclusive range. For example, to run a task on the 4th, 5th, 6th, and 20th of a
month, type 4-6,20.



Insert an asterisk to specify all values allowed for this field. For example, to run a task
daily, type * in the Day of the month text box.

To schedule the task to run every Nth period, enter the combination */N, where N is a
value for this field (minute, hour, day, month). For example, */15 in the Minute field
schedules the task to start every 15 minutes.
You can type the contracted names of months and days of the week, which are the first
three letters: Aug, Jul, Mon, Sat, etc. However, the contracted names cannot be
separated with commas or used together with numbers.

6. Specify which command to run. Type it into the Command input box.
For example, if you want to run the backup creation task at the specified time and have
the backup file sent to your e-mail, you need to specify the following command in the
Command input box:
/usr/local/psa/admin/sbin/backupmng

7. Click OK.

¾ To temporarily suspend execution of a scheduled task:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Scheduled Tasks (in the Advanced Operations
group).
3. Locate the task that you want to suspend and click the corresponding link in
the Command column.
4. Clear the Switched on checkbox and click OK.

¾ To resume execution of a scheduled task:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Scheduled Tasks (in the Advanced Operations
group).
3. Locate the task whose execution you want to resume and click the
corresponding link in the Command column.
4. Select the Switched on checkbox and click OK.
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¾ To cancel a task:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Scheduled Tasks (in the Advanced Operations
group).
3. Select a checkbox to the left of the task that you want to cancel and click
Remove.
4. Confirm removal and click OK.

Scheduling Tasks (Windows Hosting)
If you need to run scripts on your hosting account at specific time, use the task scheduler in
the Panel to make the system automatically run the scripts for you.
During installation of the Panel, the following tasks are automatically created:


Update antivirus database – updates Parallels Premium Antivirus database.



Statistics calculation - generates statistics on resource usage, such as traffic and disk
space.

As all these tasks are related to site statistics, databases and reports, it is strongly
recommended that you neither change nor remove them.

¾ To schedule a task:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Scheduled Tasks (in the Advanced Operations
group).
3. Click Schedule New Task.
4. Leave the Switched on checkbox selected if you want your scheduled task to
be active immediately after the creation.
5. Type a name for your task in the Description field.
6. In Scheduler notification, specify whether the scheduler should notify you when
it runs this task. The following options are available:


Switched off - do not notify you.



Send to the default e-mail - send the notification to your default e-mail address.
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Send to the e-mail I specify - send the notification to the e-mail specified in the
corresponding field. After selecting this option, you need to type the required e-mail
address in the field on the right.

7. Specify which command or executable file to run. Type it into the Path to
executable file input box. If you need to run the command with certain options,
type them in the Arguments field.


For example, if you want to run the statistics calculation task to count disc space and
see more detailed information for the example.com and example.net domains, you
need to specify the following path in the Path to executable file input box:
C:\Program Files\Parallels\Parallels
Panel\admin\bin\statistics.exe
and the following options in the Arguments field:
--disk-usage --process-domains=example.com, example.net –
verbose



If you want to run your own PHP script using the task scheduler, you need to specify
the following path in the Path to executable file input box:
C:\Program Files (x86)\Parallels\Parallels
Panel\Additional\PleskPHP5\php.exe
and specify the script location in the Arguments field:
C:\Inetpub\vhosts\mydomain.tld\httpdocs\myscript.php

8. Select the appropriate priority in the Task priority field. Task priority can be set
to Low, Normal or High.
9. Specify when to run your command by selecting the appropriate checkboxes
in the Hours, Days of month, Months or Days of week fields.
10. Click OK to schedule the task or click Run Now to schedule the task and
immediately run it.

¾ To temporarily suspend execution of a scheduled task:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Scheduled Tasks (in the Advanced Operations
group).
3. Choose a task that you want to suspend and click the corresponding link in
the Description column.
4. Clear the Switched on checkbox.
5. Click OK.

Hosting and Managing Websites

99

¾ To resume execution of scheduled task:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Scheduled Tasks (in the Advanced Operations
group).
3. Choose a task whose execution you want to resume and click the
corresponding link in the Description column.
4. Select the Switched on checkbox.
5. Click OK.

¾ To cancel a task:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Scheduled Tasks (in the Advanced Operations
group).
3. Select a checkbox to the left of the task that you want to cancel and click
Remove.
4. Confirm removal and click OK.
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Setting Up Mobile Sites
Your service plan may include the option to create website copies optimized for viewing on
mobile devices. The copies are hosted with external UNITY Mobile online service.

¾ To create a copy of your website optimized for viewing on mobile devices, or
set up a new mobile website:
1. Go to Websites & Domains tab > Mobile Websites.
2. Click the corresponding Create Mobile Site link.
3. Specify an address for the mobile site.
If your site is accessible, for example, by domain name example.com, you can type a
prefix like mobile, and then the optimized copy of your website will be accessible by the
address mobile.example.com.

4. Click OK.
5. Click Edit Site Content. A UNITY Mobile site opens in a new browser window or
tab, and you are logged on under your account.
6. In the Import from the web section showing your main website’s domain name,
click the button

.

7. Complete the website import wizard by following instructions presented on
the screen.
After the mobile site is created, you can add a link to it to your main site.
You can now perform the following operations on the mobile site using links in Control Panel:


Open site editor.



Remove mobile site.
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Viewing Statistics and Log Files
¾ To view the reports on disk space and traffic usage by your account:
1. If you have several subscriptions associated with your account, in the
Subscription menu at the top of the screen, select the required subscription.
2. Click the Statistics tab.
The following information is presented in charts:


Disk space used by websites, mail accounts, databases, and other files located in
your webspace.



Traffic used by FTP, web, and mail services during the current month.
FTP field shows the information about the total size of files transferred to and from the
webspace over the file transfer protocol.
HTTP field shows the information about the total amount of data transferred from all of
your websites over HTTP protocol, that is, retrieved by web browsers.
POP3/IMAP field shows the total amount of data received by all mail accounts under
your domains.
SMTP field shows the total amount of data sent by all mail accounts under your
domains.

3. Do any of the following:


To view a report on the amount of data transferred to and from your sites over FTP,
click FTP Statistics.



To view a report on the amount of data transferred to and from your FTP directory,
which is accessed without authorization, click Anonymous FTP statistics.



To view a report on the amount of traffic used by services during a certain month, click
Data Transfer Statistics, and select the required month from the menu.

¾ To find out how many people visited a site, from what countries, and what
pages of the site they viewed:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Web Statistics.
The site visitor statistics will show in a new browser window.

3. To view statistics for web pages viewed from the SSL-secured area of your
site, select SSL Web Statistics in the menu.
4. To view statistics for files downloaded over the file transfer protocol (FTP),
select FTP Statistics in the menu.
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Alternately, you can view the visits statistics for a site by visiting the following URL:
https://your-domain.com/plesk-stat/webstat. When prompted for username and password,
specify your FTP account username and password.

Working with Log Files
All connections to the web server and requests for files that were not found on the server are
registered in log files. These log files are analyzed by the statistics programs running on the
server, which then present graphical reports on demand. You may want to download these
log files to your computer for processing by third-party statistics programs, or view their
contents for web server debugging purposes.

¾ To prevent these log files from growing too large, you should enable automatic
cleanup and recycling of log files:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Logs (in the Advanced Operations group) > Log
Rotation.
3. Click Switch On. If you see only the Switch Off button there, this means that log
recycling is already switched on.
4. Specify when to recycle log files and how many copies of each log file to
store on the server. Also specify whether they should be compressed and
sent to an e-mail address after processing.
5. Click OK.

¾ To view the contents of a log file or download it to your computer:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription menu at
the top of the screen, select the required webspace.
2. Go to the Websites & Domains tab > Logs (in the Advanced Operations group). A list
of log files opens.
3. Do any of the following:


To view all entries in a log file, click the log file name. If you want to view only a few
last lines from the log file, type the number of lines into the input box under the Settings
group, and then click the log file name.



To download a file to your computer, click the corresponding icon



To remove a processed log file from the server, select the corresponding checkbox
and click Remove. Confirm removal and click OK.

.

CHAPTER 5

Backing Up and Restoring Data
This section describes how to perform the following operations in your Panel:


Back up all data related to your account and sites.



Schedule backups.



Restore data from backup archives.

In this chapter:
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Uploading, Downloading, and Removing Backup Files ...................................... 110
Uploading, Downloading, and Removing Database Backup Files (Windows Hosting)
............................................................................................................................ 111

Configuring the Panel for Working with an
FTP Repository
¾ If you are going to store backup files on an FTP server, you should specify
the FTP account credentials that should be used:
1. Go to the Account tab > Back Up My Account and Websites > Personal FTP
Repository Settings.
2. Specify the following:


FTP server's IP address or host name.



Directory on the server where you want to store backup files.



Username and password for access to the FTP account.



Passive mode option. Switch it on if the Panel experiences problems when
connecting to the remote FTP directory.

3. Click OK.
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Backing Up Data
¾ To back up all data related to your account and all your subscriptions:
1. Go to the Account tab > Back Up My Account and Websites > Back Up.
2. Specify the following:


Backup file name prefix and description. You cannot specify an arbitrary file
name, however, you can set the Panel to add a prefix to backup file names.
Note that the Panel automatically adds the date and time of backup file creation
(in Universal Time) to backup file names.



Splitting of the backup file. To create a multivolume backup, select the
corresponding checkbox and specify volume size in megabytes.



Location where to store the backup file. Select the repository where you would
like to store the backup file.



E-mail notification on backup completion. If you want to be notified of the
backup completion, type your e-mail address.



What data to back up. You can back up only the account settings or account
settings and all data.



Suspend domains until backup task is completed. Select this option to prohibit users
from making changes to content or settings of websites while they are being
backed up.
Note: If you select this option, then, after restoring the data from this backup
file, you will need to manually switch on every domain alias for every site
that needs to have domain aliases. This can be done at Websites & Domains
tab > Domain Aliases (in the Advanced Operations group) > domain alias name >
Switch On.

3. Click Back Up.
When backing up is finished, the backup file will be saved to the repository you
selected.

¾ To back up all websites related to a subscription:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription
menu at the top of the screen, select the required webspace.
2. Go to the Account tab > Back Up Websites > Back Up.
3. Specify the following:


Backup file name prefix and description. You cannot specify an arbitrary file
name, however, you can set the Panel to add a prefix to backup file names.
Note that the Panel automatically adds the date and time of backup file creation
(in Universal Time) to backup file names.
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Splitting of the backup file. To create a multivolume backup, select the
corresponding checkbox and specify volume size in megabytes.



Location where to store the backup file. Select the repository where you would
like to store the backup file.



E-mail notification on backup completion. If you want to be notified of the
backup completion, type your e-mail address.



What data to back up. You can choose to back up:





Only settings of websites.



All settings and data with or without mail accounts and messages in
mailboxes.



Only mail accounts with messages.

Suspend domains until backup task is completed. Select this option to prohibit users
from making changes to content or settings of websites while they are being
backed up.
Note: If you select this option, then, after restoring the data from this backup
file, you will need to manually switch on every domain alias for every site
that needs to have domain aliases. This can be done at Websites & Domains
tab > Domain Aliases (in the Advanced Operations group) > domain alias name >
Switch On.

4. Click Back Up.
When backing up is finished, the backup file will be saved to the repository you
selected.

In this section:
Scheduling Backups............................................................................................ 106
Backing Up Databases (Windows Hosting) ........................................................ 107
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Scheduling Backups
¾ To schedule backing up of data:
1. Go to the Account tab > Back Up My Account and Websites > Scheduled Backup
Settings.
2. Select the Activate this backup task checkbox and specify the following:


When and how often to run the backup.



A prefix that should be added to the backup file name.



Splitting of the backup file. To create a multivolume backup, select the
respective checkbox and specify volume size in megabytes. Note that volume
size cannot exceed 4095 megabytes.



Location where to store the backup file. Select the repository where you would
like to store the backup file.



Maximum number of backup files stored in the repository. Type a number if you
want to recycle backup files: When this limit is reached, the oldest backup files
are removed.



E-mail notification on backing up errors. If you want to send an e-mail notice
when something goes wrong during backing up, type the e-mail address you
need.



What data to back up. You can back up only account settings, or account
settings and all related data.



Suspend domains until backup task is completed. Select this option to prohibit users
from making changes to content or settings of websites while they are being
backed up.

3. Click OK.
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Backing Up Databases (Windows Hosting)
If you are using a Windows-based hosting account, then you can back up and
subsequently restore the databases, database user accounts and data used by your
websites.
You can:


Back up your domain databases with all data and user accounts.



Restore databases from backup files.



Download, upload and remove database backup files.



Recover users who became orphaned after the restoration.

¾ To back up databases:
1. Go to the Websites & Domains tab > Backup Manager > Database Backup
Repository.
2. Using the Database menu, select the databases you want to back up.
3. Click Back Up.
4. Specify the name of the backup file and click OK.
5. If you want to download the resulting backup file, click the file name on
the next page after the backup process was finished. Specify the
location where you want to save the file and click Save.
6. Click OK.
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Restoring Data
¾ To restore data from a backup file:
1. Go to the Account tab > Back Up My Account and Websites.
2. Click the name of the backup file that you want to restore.
3. Specify the following settings:


Types of data to be restored.



Suspend domains until restoration task is completed. Select this if you want to avoid
possible conflicts that may occur when users modify site content or settings
while they are being restored.



Type your e-mail address if you want the Panel to notify you when restoring is
completed.



Conflicts resolution policy. Specify what to do if any conflicts occur during
restoration.

4. Click Restore.
In case if any errors or conflicts occur during restoration of data, the wizard will
prompt you to select an appropriate resolution. Follow the instructions provided on
the screen to complete the wizard.

In this section:
Restoring Databases (Windows Hosting) ............................................................109
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Backing Up and Restoring Data

109

Restoring Databases (Windows Hosting)
¾ If the database already exists and you only need to restore its contents:
1. Go to the Websites & Domains tab > Backup Manager > Database Backup
Repository.
2. Select the required backup file from the list and click Restore Selected.
If you do not have the backup file on the server, you can upload the backup file to
the server repository from your local machine. For more information, refer to the
section Uploading, Downloading, and Removing Database Backup Files.

3. Confirm the restoration by selecting the corresponding checkbox and
click OK.
If you are restoring an MS SQL database, there is a possibility that some database
users will be orphaned. In order to provide the ability to access and use the
database for these users, you need to repair them. For more information, refer to
the section Recovering Orphaned Database Users.

Recovering Orphaned Database Users (Windows
Hosting)
If you are restoring an MS SQL database, there is a possibility that some database
users will be orphaned. In order to provide the ability to access and use the database
for these users, you need to repair them.

¾ To check if a database has orphaned users and to repair them:
1. Go to Websites & Domains tab > Databases (in the Advanced Operations group)
> database name.
2. If you see a warning saying that there are several orphaned users that
should be repaired in order to function properly, you have orphaned
users who need to be repaired.
3. To repair orphaned users, click the Repair now button corresponding to
the users you want to repair.
4. Provide password for the users and click Repair.
If a user is supposed to be a system user without a password, run repair with empty
password field.
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Uploading, Downloading, and Removing
Backup Files
¾ To upload a backup file to a backup repository on the server:
1. Go to the Account tab > Back Up My Account and Websites.
2. Click Upload Files to Server Repository.
3. Click Browse and select the required backup file.
4. Click OK.
The backup file will be uploaded to the backup repository.

¾ To download a backup file from a backup repository within Panel:
1. Go to the Account tab > Back Up My Account and Websites.
2. Click an icon

corresponding to the backup file you want to download.

3. Select the location where you want to save the backup file and click
Save.
The backup file will be downloaded from the backup repository.

¾ To remove a backup file from a backup repository in Panel:
1. Go to the Account tab > Back Up My Account and Websites.
2. Select a checkbox corresponding to the backup file you want to remove.
3. Click Remove.
4. Confirm removal and click OK.
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Uploading, Downloading, and Removing
Database Backup Files (Windows
Hosting)
¾ To upload a backup file to backup repository:
1. Go to the Websites & Domains tab > Backup Manager > Database Backup
Repository and click Upload Backup File.
2. Select the database in whose repository you want to upload the backup
file to in the Database name menu.
3. Click Browse... and select the required backup file.
4. Leave the Restore database backup immediately upon uploading checkbox
selected if you want the database contents to be restored immediately
after the backup file is uploaded.
5. Click OK.
The database backup file will be uploaded to the backup repository of the specified
database.

¾ To download a backup file from backup repository:
1. Go to the Websites & Domains tab > Backup Manager > Database Backup
Repository.
2. In the Database menu, select the database whose backup files you want
to browse. Leave All domain databases selected if you want to browse
backup files of all databases on a domain.
3. Click the icon
download.

corresponding to the database backup file you want to

4. Select the location where you want to save the backup file and click
Save.
The backup file will be downloaded from the backup repository.

¾ To remove a backup file from backup repository:
1. Go to the Websites & Domains tab > Backup Manager > Database Backup
Repository.
2. In the Database menu, select the database whose backup files you want
to remove. Leave All domain databases selected if you want to browse
backup files of all databases on a domain.
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3. Select a checkbox corresponding to the database backup file you want
to remove. Click Remove, confirm removal and click OK.

CHAPTER 6

Using E-mail Services
You can set up and use the following types of e-mail services:


Mailboxes associated with your domain names.



Mailing lists: e-mail addresses to which a number of users are subscribed. Mailing
lists are useful for distributing news, promotions, or setting up group discussions.



E-mail aliases: additional e-mail addresses that are associated with a user's
primary (or main) e-mail address. E-mail aliases can be used as temporary
disposable addresses that can be published on the Internet. When spam starts
coming to an address that was set up as an e-mail alias, you can remove that alias
and create another one.



E-mail forwarding: for each e-mail account, you can set up e-mail forwarding
service that will send copies of all incoming messages to another e-mail address.



Automatic response: for each e-mail account, you can switch on automatic
response service, which will send a predefined e-mail message in reply to any
incoming e-mail message. This is useful for sending "out of office" or "on vacation"
notices when you are away.

In this chapter:
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Setting Up Global Mail Service Settings
You can configure the following mail service settings that apply to all domains created
under a subscription:


Mail service status. You can switch the mail service on or off. If the mail service is
switched off, then e-mail messages cannot be sent or received.



Mail bounce settings. When somebody sends an e-mail message to an e-mail
address that does not exist under your domain, the mail server, by default, accepts
mail, processes it, and when it finds out that there is no such a recipient under the
domain, it returns the mail back to sender with an error message. You can choose
to:





Continue returning all such mail back to senders (Bounce with message option),



Forward all such mail to the specified e-mail address (Forward to address option),



Forward all such mail to another mail server with the specified IP address using
the option Redirect to external mail server with IP address (available only for
Windows hosting),



Reject such mail without accepting it and without notifying senders (Reject
option).

Webmail. If your service plan provides the option to choose which webmail program
to use for your account, then you can select it in the global mail settings.

¾ To configure the mail service settings:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription
menu at the top of the screen, select the required webspace.
2. Go to the Mail tab, and then click Change Settings.
3. Select the required options, and click OK.
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Setting Up E-mail Addresses
¾ To create an e-mail address:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription
menu at the top of the screen, select the required webspace.
2. Click the Mail tab.
3. Click Create E-mail Address.
4. Type the left part of the e-mail address before the @ sign, and, if you
have several domain names on your account, select the domain name
under which the e-mail address will be created.
5. Leave the Mailbox checkbox selected.
Clearing this checkbox makes sense only if you want to use this address as a mail
forwarder, which will forward all incoming mail to another address.

6. Specify the mailbox size or use the default size defined by the
provider's policy or your service plan.
7. Specify a password consisting of five or more Latin characters.
8. Click OK.

¾ To remove an e-mail address:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription
menu at the top of the screen, select the required webspace.
2. Click the Mail tab.
3. Select a checkbox corresponding to the e-mail address you want to
remove and click Remove.
4. To confirm removal, click Yes.
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Setting Up E-mail Aliases
¾ To add or remove additional e-mail addresses (e-mail aliases) for a mail
account:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription
menu at the top of the screen, select the required webspace.
2. Go to the Mail tab > e-mail address > E-mail Aliases tab.
3. Do any of the following:


To add an address, type it into the E-mail alias box, and click OK.



To remove an address, click the Remove link to the right of the address you want
to remove.
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Setting Up Mail Forwarding
¾ To set up e-mail forwarding for an e-mail address:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription
menu at the top of the screen, select the required webspace.
2. Go to the Mail tab > e-mail address > Forwarding tab.
3. Select the Switch on mail forwarding checkbox.
4. Specify one or several e-mail addresses to which e-mail must be
forwarded. When specifying e-mail addresses, separate them with white
spaces, commas, semicolons, or type each of them on a new line.
5. Click OK.
6. If you do not want to keep copies of forwarded messages in the
mailbox, go to the Mail tab > e-mail address, clear the Mailbox checkbox,
and click OK.

¾ To switch off mail forwarding:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription
menu at the top of the screen, select the required webspace.
2. Go to the Mail tab > e-mail address > Forwarding tab.
3. Clear the Switch on mail forwarding checkbox, and click OK.
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Setting Up Auto-Reply
¾ To set up automatic reply for an e-mail address:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription
menu at the top of the screen, select the required webspace.
2. Go to the Mail tab > e-mail address > Auto-Reply tab.
3. Select the Switch on auto-reply checkbox, and specify the following
settings:


Auto-reply message subject.



Message format. We recommend that you leave the option Plain text selected
because some of your recipients might be unable to see the text formatted with
HTML.



Encoding. We recommend that you leave the UTF-8 encoding selected to ensure
that the letters in your message are displayed properly.



Message text.



Forwarding address. If you want to forward incoming messages to another e-mail
address, type an e-mail address in this box.



Attached files. If you want to attach a file to your message, click Browse and select
a file.

4. Click OK.

¾ To switch off automatic reply for an e-mail address:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription
menu at the top of the screen, select the required webspace.
2. Go to the Mail tab > e-mail address > Auto-Reply tab.
3. To switch off automatic reply, clear the Switch on auto-reply checkbox, and
click OK.
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Setting Up Protection from Viruses
To defend your system from viruses, do not open suspicious e-mail attachments,
enable antivirus protection on the server side, if this service is provided by your hosting
company, and be sure to have a firewall and antivirus software installed on your
personal computer. Also keep your operating system up-to-date and timely install
security hot fixes and patches.

¾ To switch on antivirus protection for a mailbox:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription
menu at the top of the screen, select the required webspace.
2. Go to the Mail tab > e-mail address > Antivirus tab.
3. Select the checkbox Switch on antivirus protection for this e-mail address.
4. Choose the desired mail scanning mode. You can switch on scanning
for incoming mail, outgoing mail, or both.
5. Click OK.
When an infected message comes, you will be notified by e-mail. If Kaspersky Antivirus
is used by your provider, then you might be able to configure it at the Mail tab > e-mail
address > Antivirus tab.

¾ To switch off antivirus protection for a mailbox:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription
menu at the top of the screen, select the required webspace.
2. Go to the Mail tab > e-mail address > Antivirus tab.
3. Clear the checkbox Switch on antivirus protection for this e-mail address.
4. Click OK.

120

Using E-mail Services

Setting Up Protection from Spam
¾ To switch on spam filtering for a mailbox:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription
menu at the top of the screen, select the required webspace.
2. Go to the Mail tab > e-mail address > Spam Filter tab.
3. Select the checkbox Switch on spam filtering for this e-mail address.
4. Specify what to do with messages classified as spam.


If you are sure that your spam filter is accurate, you may want to set the filter to
automatically delete all incoming messages recognized as spam. To do this,
select the option Delete all spam messages.



If you want to filter mail with the software on your local computer, select the
option Mark spam messages by adding the following text to message subject, and then
specify how spam filter should mark the messages recognized as spam. "XSpam-Flag: YES" and "X-Spam-Status: Yes" headers are added to the
message source by default, and if you want, the spam filter will also add a
specific text string to the beginning of the subject line and to the message body.

5. If you want to adjust spam filter sensitivity, click Show Advanced Settings,
and type a number of points that a message must score to be
considered spam.
SpamAssassin performs a number of different tests on contents and subject line of
each message. As a result, each message scores a number of points. The higher
the number, the more likely a message is spam. For example, a message
containing the text string "BUY VIAGRA AT LOW PRICE!!!" in subject line and
message body scores 8.3 points. By default, the filter sensitivity is set so that all
messages that score 7 or more points are classified as spam.


If you receive lots of spam messages with the current setting, to make filter
more sensitive, try setting a lesser value in the Spam filter sensitivity box; for
example, 6.



If you are missing your e-mails because your spam filter thinks they are junk, try
reducing filter sensitivity by setting a higher value in the Spam filter sensitivity box.

Note: To further improve spam filter accuracy, you may want to train your spam
filter on e-mail messages you receive, as described further in this section.

6. If you want to be sure that you will not miss e-mail from specific
senders, type e-mail addresses or domain names into the White list field.
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Place each address in one row, or separate addresses with a coma, a colon, or a
white space. You can use an asterisk (*) as a substitute for a number of letters, and
question mark (?) as a substitute for a single letter. For example:
address@mycompany.com, user?@mycompany.com, *@mycompany.com.
Specifying *@mycompany.com will add to the white list all e-mail addresses that
are under the mycompany.com mail domain.

7. If you do not want to receive e-mail from specific domains or individual
senders, type e-mail addresses or domain names into the Black list field.
Place each address in one row, or separate addresses with a coma, a colon, or a
white space. You can use an asterisk (*) as a substitute for a number of letters, and
question mark (?) as a substitute for a single letter. For example:
address@spammers.net, user?@spammers.net, *@spammers.net. Specifying
*@spammers.net will block the entire mail domain spammers.net.

8. If you use a Windows-based hosting account, then you can also specify
trusted languages and character sets. E-mail messages written in the
specified languages and with the defined character sets will pass the
spam filter and will not be marked as spam.
9. On Windows-based hosting accounts, you can also specify IP
addresses of computers or networks from which e-mail must always be
accepted. When specifying network addresses, type an address and
add a network mask after a slash. For example, 192.168.10.10/24.
10. Click OK.

¾ To improve accuracy of spam detection, if SpamAssassin spam filter is
switched on for your account:
1. Access your mailbox with webmail or a mail client program on your
computer.
2. Review the messages in your Inbox folder. Move all spam messages to
the Spam folder. This will make the SpamAssassin spam filter recognize
spam more efficiently.
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Accessing Mailboxes
There are two ways to access a mailbox for sending and receiving e-mail messages:


Set up and use an e-mail client program on your computer.



Use a web browser to connect to the webmail interface. Webmail interface is
provided by Horde IMP Webmail software, which is installed by default. You can
either use the default Horde IMP Webmail, or install Atmail Webmail Lite software.

¾ To access webmail, do any of the following:


In a Web browser, visit the URL webmail.example.com, where example.com is the
Internet address of your website. When prompted, specify your full e-mail address
as the username (for example, mail@example.com), and specify the password that
you use for logging in to the Panel.



When logged in to the Panel, click the Mail tab, and in the list of e-mail addresses,
click an icon
corresponding to the e-mail address you need.

In this section:
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Setting Up Microsoft Office Outlook 2007
¾ To set up Microsoft Office Outlook 2007:
1. Open Microsoft Office Outlook.
2. Go to Tools > Account Settings.
3. On the E-mail tab, click New.
4. Leave the option Microsoft Exchange, POP3, IMAP, or HTTP selected. Click
Next.

5. Select the checkbox Manually configure server settings or additional server types.
Click Next.
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6. Select the Internet E-mail option and click Next.

7. Specify the following:


Your name.
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Your e-mail address.



Account type. If you want to keep copies of messages on the server, select the
IMAP option. If you do not want to keep any messages on the server, select the
POP3 option. Selecting IMAP will also allow you to train the SpamAssassin
spam filter on e-mail messages you receive, if SpamAssassin is enabled on the
server.



Incoming mail server. Type your domain name. For example, example.com.



Outgoing mail server. Type your domain name. For example, example.com.



Username for logging in to the mailbox. Specify your full e-mail address.



Password for logging in to the mailbox. Most likely, this password coincides with
the password you use for logging in to the Panel.

8. Click Next.
9. Click Finish.
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Setting Up Microsoft Outlook Express 6
The instructions provided in this section were verified against Microsoft Outlook
Express 6. They might not work with earlier or later versions of Microsoft Outlook
Express.

¾ To set up Microsoft Outlook Express:
1. Open Microsoft Outlook Express.
2. Go to Tools > Accounts.
3. Click the Add button and select the Mail item.
4. Enter your name as you want it to appear in any messages you send,
and click Next.

5. Type your e-mail address, and click Next.
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6. Specify the following settings:


Protocol of your incoming mail server.
If you want to keep copies of messages on the server, select the IMAP option. If
you do not want to keep any messages on the server, select the POP3 option.
Selecting IMAP will also allow you to train the SpamAssassin spam filter on email messages you receive, if SpamAssassin is enabled on the server.



Incoming mail server. Specify your website's Internet address.



Outgoing mail server. Specify your website's Internet address.
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7. Click Next.
8. Specify the following:


Your account name. Type your e-mail address in the Account name box.



Your password. Most likely, this password coincides with the password you use
for logging in to the Panel.



Remember password checkbox. Leave it selected if you do not want to be
prompted to enter password each time your e-mail program connects to the mail
server to check for new mail, and click Next.
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9. To complete setting up your e-mail program, click Finish.
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Setting Up Mozilla Thunderbird
The instructions provided in this section were verified against Mozilla Thunderbird 2.
They might not work with earlier or later versions of Mozilla Thunderbird.

¾ To set up Mozilla Thunderbird:
1. Open Mozilla Thunderbird.
2. Go to Tools > Account Settings.
3. Click Add Account.
The Account Wizard opens.

4. Leave the Email account option selected, and click Next.

5. Specify the following:


Your name, as you want it to appear in any messages you send.



Your e-mail address.
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6. Click Next.
7. Specify the following:


Protocol of your incoming mail server.
If you want to keep copies of messages on the server, select the IMAP option. If
you do not want to keep any messages on the server, select the POP3 option.
Selecting IMAP will also allow you to train the SpamAssassin spam filter on email messages you receive, if SpamAssassin is enabled on the server.



Incoming server address. Specify your website's Internet address.



Outgoing server address. Specify your website's Internet address.
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8. Click Next.
9. In the Incoming User Name box, specify your full e-mail address.
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10. Click Next.
11. Enter the name by which you would like to refer to this account (for
example, Work Account) and click Next.

12. Verify that the information you entered is correct, and click Finish.
13. Click OK to close the Account Settings wizard.
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Setting Up Apple Mail
The instructions provided in this section were verified against Apple Mail 3.6 (Leopard).
They might not work with earlier or later versions of Apple Mail.

¾ To set up Apple Mail:
1. Run Apple Mail.
If you run it for the first time and do not have any mail accounts configured in it, skip
the next step: Apple Mail will take you directly to creating one.

2. Open the Adding Mail Account wizard:
a. Click Mail > Preferences....
b. Select the Accounts tab.
c. Click the + button at the bottom left corner.
3. Enter the account information:


Your full name



Your full e-mail address



The password you use to log in to the Panel.

4. Click Continue.
5. Fill in the following incoming mail server information:


Account Type: select whether you want to use IMAP or POP protocol.
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We recommend selecting IMAP if you use SpamAssassin as a spam filtering
solution: IMAP account is a requirement for SpamAssassin learning which
messages are spam and which are not.


Incoming Mail Server: type in the name of domain which serves your mail (which
follows the @ sign in your e-mail address).



User Name: enter your full e-mail address.



Password: leave it auto-completed (Apple Mail takes it from the previous step).

6. Click Continue.
7. (Optional) Specify the incoming mail security options:
a. Select the Use Secure Sockets Layer (SSL) checkbox.
b. Select the authentication method.
Keep the default method if you are not sure which to select.
Apple Mail displays this setup screen only if a mail server bundled with Parallels
Small Business Panel supports SSL for the selected account type (POP or IMAP).
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8. Click Continue.
9. Fill in the following outgoing mail server information:


Outgoing Mail Server: type in the name of domain which serves your mail (which
follows the @ sign in your e-mail address).



Use only this server: selected.



Use Authentication: selected.



User Name: enter your full e-mail address.



Password: leave it auto-completed (Apple Mail takes it from the previous step).
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10. Click Continue.
Apple Mail displays overall description of the mail account that is going to be
created.

11. Select the Take account online checkbox and click Create.
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Setting Up Mailing Lists
Mailing list is a group e-mail address to which a number of users are subscribed.
Mailing lists are used for sending e-mail messages to multiple recipients at once. Email messages sent to mailing list subscribers can include anything from plain text to
colorful newsletters and promotions with embedded images and links, and attached
multimedia and presentation materials.
How it all works: you create a mailing list e-mail address in the Panel, and subscribe
users to it. Then you send your message to the mailing list address, and all subscribers
receive it.

¾ To set up a mailing list and subscribe users to it:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription
menu at the top of the screen, select the required webspace.
2. Go to the Mail tab > Mailing Lists tab.
3. Click Create Mailing List.
4. Type the mailing list address and, if you have several websites, select
the website under which the mailing list will be created.
5. To subscribe users to the mailing list, type their e-mail addresses, one
address per line.
6. To notify the mailing list administrator about mailing list creation, select
the checkbox Notify administrator on the mailing list creation.
7. Click OK.

¾ To subscribe or unsubscribe users:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription
menu at the top of the screen, select the required webspace.
2. Go to the Mail tab > Mailing Lists tab.
3. Click the mailing list address.
4. Do any of the following:


To subscribe users to the mailing list, type their e-mail addresses into the
Subscribers field, one address per line.



To unsubscribe users, remove their addresses from the Subscribers field.

5. Click OK.
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¾ To remove a mailing list:
1. If you are subscribed to several hosting packages and have access to
several webspaces associated with your account, in the Subscription
menu at the top of the screen, select the required webspace.
2. Go to the Mail tab > Mailing Lists tab.
3. Select a checkbox corresponding to the mailing list you want to remove
and click Remove.
4. To confirm removal, click Yes.

¾ To switch off the mailing lists service and all mailing lists created under
the currently selected subscription:
1. Go to the Mail tab > Mailing Lists tab.
2. Click Switch Off the Service.

¾ To switch on the mailing lists service for the currently selected
subscription:
1. Go to the Mail tab > Mailing Lists tab.
2. Click Switch On the Service.

CHAPTER 7

Adding User Accounts
If you want to allow other users to access the Panel for managing websites, installed
applications, or use e-mail services under your domains, then you need to create user
accounts for them.
User accounts are created based on user roles. The roles include privileges to access
certain areas of the Panel and perform operations in the Panel. There are several
predefined user roles called Accountant, Application User, Owner, and Webmaster.
You can review and modify the Accountant, Application User, and Webmaster roles to
suit your needs, or you can create your own custom roles.
After user accounts are created, the users will be able to log in to their accounts in the
Panel and use shortcuts in their Panels to access their mailboxes and work with
applications.

¾ To create a user role:
1. Go to the Users tab > User Roles tab > Create User Role.
2. Specify the following:


User role name.



Privileges. Grant the required permissions for operations to the user:


Manage users and roles. Add, modify, and remove user accounts and roles.
Note that even if this permission is not granted to a user, the user will be
able to browse contact information of other users after logging in to the
Panel.



Create and manage sites. Set up, modify, remove domain names and
subdomains, host websites and change web hosting settings.



Configure log rotation. Manage settings for recycling of web server access and
error log files. View, download, and remove log files.



Configure anonymous FTP service. Set up a directory accessible to all Internet
users over FTP without authorization.



Create and manage scheduled tasks. Schedule execution of scripts or programs
on your hosting account.



Configure spam filter. Set up spam protection for mailboxes.



Configure antivirus. Set up virus protection for mailboxes.



Create and manage databases. Add, modify, and remove databases stored on
your hosting account.



Configure and perform data backup and restoration. Back up and restore data
related to your hosting account, websites, and mailboxes under your
domains.
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View statistics. View reports on disk space and traffic usage by your websites,
and website visits.



Install and manage applications. Install applications on websites and manage
them.



Design sites in SiteBuilder. Create websites using SiteBuilder.



Upload and manage files. Manage files and directories located in the webspace
by using the Panel's file manager.



Create and manage additional FTP accounts. Set up additional FTP accounts for
other users.



Manage DNS settings. Manage DNS settings for domains.



Install and manage Java applications. Install on websites third-party Java
applications.



Create and manage mail accounts. Create, modify, and remove e-mail accounts.



Create and manage mailing lists. Create, modify, and remove mailing lists.

Access to applications. Select the applications that the user should be able to
access and use. All web applications installed on the server are listed in this
area.
For more information about installing applications and providing access to
users, refer to the section Installing Applications (on page 31).

3. Click OK.

¾ To modify user role properties:
1. Go to the Users tab > User Roles tab.
2. Click a link with the role name that you want to change.
3. Change the role properties as required and click OK.

¾ To remove a user role:
1. Go to the Users tab > User Roles tab.
2. Select a checkbox corresponding to the role you want to remove and
click Remove. Note that it is impossible to remove the Owner role and
other roles that are assigned to one or more users.
3. Click Yes to confirm the removal.

¾ To create a user account:
1. Go to the Users tab > Create User Account.
2. Specify the following:


Contact name.



E-mail address. The e-mail address will be used as a username for logging in to
the Panel.
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To create a new e-mail address for the user, select the option Create an e-mail
address under your account,
type the desired left part of the address which goes before the @ sign, and,
if you have a number of domains on your account, select the domain name
under which the e-mail address should be created.



To associate with this user account an external e-mail address, select the
option Use an external e-mail address, and specify an existing external e-mail
address.



User role. Select the required user role from the menu.



Password. Type the password for access to the Panel.

3. Leave the User is active checkbox selected. Otherwise, the user will not
be able to access the Panel and use applications on your hosting
account.
4. Click OK.
5. Now, if you want to add contact information for the user, click a link with
the user's name, and then click the Contact Details tab, and specify the
user's contact information.
6. Click OK.
Now you can notify the user about creation of his or her account and ability to access
the Panel. Provide the user with the address to open in his or her browser, the
username (which is the user's e-mail address), and the password that you specified in
the account settings.

¾ To change user account properties:
1. Click the Users tab.
2. Click a link with the user's name.
3. Make the required changes and click OK.

¾ To suspend or activate a user account:
1. Click the Users tab.
2. Click a link with the user's name.
3. Do any of the following:


To suspend a user account, clear the User is active checkbox. The user will no
longer be able to log in to the Panel and access applications.



To activate a user account, select the User is active checkbox.

4. Click OK.

¾ To remove a user account:
1. Click the Users tab.
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2. Select a checkbox corresponding to the user account you want to
remove, and click Remove. Note that you cannot remove your own
account.
3. Click Yes to confirm the removal.
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CHAPTER 8

Adding and Removing Custom Buttons
You can add custom hyperlink buttons to the Panel and make them visible for your
users. The links may lead to web resources, such as your corporate site, or to a web
application that can process online requests and accept additional information about
the users who click these links.
You can specify what information about users should be passed:


Subscription ID.



Primary domain name associated with a subscription.



FTP account username and password.



Customer's account ID, name, e-mail, and company name.

You can place the buttons in the following locations of the Control Panel, and decide
who should be able to see them:


On the Home page in the Control Panel, visible only to you. This is achieved by
selecting the Customer's Home page option in the button properties.



On the Home page in the Control Panel, visible to you and your users who are
allowed to log in to the Control Panel. This is achieved by selecting the Common
access option in the button properties.



On the Websites & Domains tab in the Control Panel, visible to you and your users
who are allowed to log in to the Control Panel. This is achieved by selecting the
Websites & Domains page of Subscription option in the button properties.

¾ To add a custom hyperlink button to the Control Panel:
1. Go to the Account tab > Custom Buttons, and click Create Custom Button.
2. Specify the following properties of the button:


Type the text that will show on your button in the Button label box.



Choose the location for your button.



Specify the priority of the button. Your custom buttons will be arranged in the
Panel in accordance with the priority you define: the lower the number, the
higher the priority. Buttons are placed in the left-to-right order.



To use an image for a button background, type the path to its location or click
Browse to browse for the desired file. It is recommended that you use a 16x16
pixels GIF or JPEG image for a button to be placed in the navigation pane, and
32x32 pixels GIF or JPEG image for buttons placed in the main frame or
desktop.



Type the hyperlink of your choice to be attached to the button into the URL box.



Using the checkboxes, specify whether you want the customer information and
other data to be transferred within the URL. These data can be used for
processing by external web applications.
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In the Context help tip contents input field, type in the help tip that will be displayed
when the users place the mouse pointer over the button.



Select the Open URL in Parallels Plesk Panel checkbox if you want the destination
URL to be opened in the main frame of the Panel, otherwise, leave this
checkbox cleared to open the URL in a separate browser window or tab.



If you want to make this button visible only to you, select the Show to me only
checkbox.

3. Click Finish to complete creation.

¾ To remove a hyperlink button from the Panel:
1. Go to the Account tab > Custom Buttons.
2. Select a checkbox corresponding to the button that you want to remove
and click Remove.

